Topic Title: Can't install drivers
Topic Summary:
Created On: 10/22/2013 05:36 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 10/22/2013 05:36 AM
User is offline View Users Profile Print this message

Author Icon
ja124
Peon

Posts: 3
Joined: 10/22/2013

Hello,

I just finished up my new PC with a R9-270X. So, I would like to install the driver. First, I tried with the Sapphire CD which was with my card, but it doesn't work, I tried after with this links

http://support.amd.com/en-us/kb-articles/Pages/latest-catalyst-windows-beta.aspx

and the Automatically Detect and Install file, but in the 2 cases, I had error messages which said I have not AMD card (what ?).

Have you an issue to my problem ?

Thank you in advance and sorry for my approximate english.

 

PS : If it can help you, the autodetect program says I have a "AMD Radeon(TM) HD 8800 Series (Microsoft Corporation - WDDM v1.3)" card and the "aticfx32.dll" driver, but I don't know what it means.

 

 10/22/2013 12:08 PM
User is offline View Users Profile Print this message

Author Icon
WMudrockJr
Overclocker

Posts: 705
Joined: 04/01/2013

The Sticky Read Before Posting details the information that is needed on the forum to assist you. Please provide that information and somebody will be able to start helpoing you.

Thanks



-------------------------

AMD A10-5800K, XFX 7850 Ultra OC Edition 975MHz, 16GB RAM, Win 8.1 Pro 64 bit, MSI 7778 motherboard, 500W PSU, HP P7-1235, CCC 13.12 WHQL

 10/22/2013 03:55 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4849
Joined: 12/27/2008

 

Originally posted by: ja124 PS : If it can help you, the autodetect program says I have a "AMD Radeon(TM) HD 8800 Series (Microsoft Corporation - WDDM v1.3)" card and the "aticfx32.dll" driver, but I don't know what it means.

It means you have windows 8.1 and one of the latest cards. This also means that its impossible that your driver CD was printed in the last 4 days, so it probably doesn't have windows 8.1 drivers.

Try 13.11 beta and if it doesn't work, you'll have to wait or use a less recent operating system. Or just stick to your current driver you have from windows update. It should provide basic functionality.

Also note that based on what other users experience, if you had 8 vanilla with a non-8.1-compatible Catalyst package installed and you used the store upgrade to get to 8.1, your system may be broken.

In that case I suggest you get a 8.1 ISO, install the system clean and try 13.11. Do it in a temp partition if you don't want to mess with your current system, then if it works, you can do it in a more permanent manner.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 10/22/2013 06:13 PM
User is offline View Users Profile Print this message

Author Icon
ja124
Peon

Posts: 3
Joined: 10/22/2013

Originally posted by: WMudrockJr The Sticky Read Before Posting details the information that is needed on the forum to assist you. Please provide that information and somebody will be able to start helpoing you.

 

Thanks

 

 

I have :

- processor Intel i5 4670 K

- motherboard Asus Z87 K

- Windows 8.1 Home 64 bits

And my graphic card is the Sapphire " Dual-X R9 270X 2 Go OC "

 

I think it's all that it can help you.

 

Originally posted by: Eydee  

Originally posted by: ja124 PS : If it can help you, the autodetect program says I have a "AMD Radeon(TM) HD 8800 Series (Microsoft Corporation - WDDM v1.3)" card and the "aticfx32.dll" driver, but I don't know what it means.

It means you have windows 8.1 and one of the latest cards. This also means that its impossible that your driver CD was printed in the last 4 days, so it probably doesn't have windows 8.1 drivers. Try 13.11 beta and if it doesn't work, you'll have to wait or use a less recent operating system. Or just stick to your current driver you have from windows update. It should provide basic functionality. Also note that based on what other users experience, if you had 8 vanilla with a non-8.1-compatible Catalyst package installed and you used the store upgrade to get to 8.1, your system may be broken. In that case I suggest you get a 8.1 ISO, install the system clean and try 13.11. Do it in a temp partition if you don't want to mess with your current system, then if it works, you can do it in a more permanent manner.

Yes I have Windows 8.1, but I have ever tried to install the Catalyst 13.11 driver with this link : http://support.amd.com/en-us/kb-articles/Pages/latest-catalyst-windows-beta.aspx

but I doesn't work, it says I have no AMD card, and it's the same thing with the autodetect program.

 

I don't know what you mean with "8 Vanilla", but I finished up my PC this week-end, and I installed directily Windows 8.1 on it, not 8.

 

So, you advice to me to wait the next drivers ? Or maybe to trying to install the older ?

 

Thanks for your helps.

 10/22/2013 06:21 PM
User is offline View Users Profile Print this message

Author Icon
ja124
Peon

Posts: 3
Joined: 10/22/2013

I just tried an other way to solve my problem, and I sucessed lol ..

It was just enough to install the Catalyst 13.11 driver, but not with the 64 bits version, with the general version. That's so strange.

 

Thank you for your helps.

 10/22/2013 06:24 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4849
Joined: 12/27/2008

It is indeed strange as there is only one version. The 32/64 links further down are for mobility.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

Statistics
84330 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.