Topic Title: Problems still exist with 13.xx drivers
Topic Summary: 13.xx drivers causing flickering within games that worked fine with the 12.10 driver
Created On: 10/22/2013 07:43 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 10/22/2013 07:43 PM
User is offline View Users Profile Print this message

Author Icon
MrDimn
Peon

Posts: 7
Joined: 05/17/2013

Greetings - 

 My machine played games just fine, from Sid Meier's Pirates to Crysis 2, and a number of other games. 

I went from 12.10 to 13.4. then to 13.10.

Yes, it is a big jump but I thought it might be time to make the change to the newer drivers.

 With my games, I am seeing video flickering and FPS issues and the only thing I changed was my video driver at that time.  

Now I have updated all of the drivers on my box, and I am still having problems.  I updated the .Net software, and I am still having problems. 

This is rather frustrating.  

 My system info is as follows:

 1)Chip set:  i7 980X

2) Video Card: ATI 5970

3) OS: Win 7 - 64 bit

4) Video Driver: Now: 13.10 - previously: 12.10

5) Power Supply: Not sure of Power Supply, but it's 1000 W.

6) Memory: 12 GB Patriot RAM

7)  I built the system myself, and I have only added hard drives over time. But that was way before I made the change.

8) Monitor: LG E2350 1920x1200

 

Any and all info is appreciated.

 

Doug

 10/22/2013 11:55 PM
User is offline View Users Profile Print this message

Author Icon
WMudrockJr
Overclocker

Posts: 705
Joined: 04/01/2013

Doug I would un-install your current driver set via the control panel. Then run the Device Driver Un-installer at the link I provided. After this put the 12.10 set back in place.

Remember the old saying if ain't broke don't mess with it. The only time you need to upgrade would be to correct an issue or support for a new game.

Link:

https://docs.google.com/file/d/0B0CqLU9SU7_0Q0ZHUDFvdW5XeVE/edit?usp=sharing&pli=1



-------------------------

AMD A10-5800K, XFX 7850 Ultra OC Edition 975MHz, 16GB RAM, Win 8.1 Pro 64 bit, MSI 7778 motherboard, 500W PSU, HP P7-1235, CCC 13.12 WHQL

 10/23/2013 05:08 AM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4846
Joined: 12/27/2008

I would not recomment running any 3rd party cleaners. The first thing you should do is making a video of this flickering. You see, it's only you having this, and we don't know exactly what's wrong. Flickering can mean a lot of things.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 10/23/2013 09:02 AM
User is offline View Users Profile Print this message

Author Icon
black_zion
80 Column Mind

Posts: 12209
Joined: 04/17/2008

I had my 5970 since the day of release up until a few months ago and I always had a flickering issue. I just learned to ignore it.

-------------------------
ASUS Sabertooth 990FX/Gen3 R2, FX-8350 w/ Corsair H60, 8 GiB G.SKILL RipjawsX DDR3-2133, XFX HD 7970 Ghz, 512GB Vertex 4, 256GB Vector, 240GB Agility 3, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, HP ZR2440w, Win 7 Ultimate x64
 02/19/2014 11:15 PM
User is offline View Users Profile Print this message

Author Icon
MrDimn
Peon

Posts: 7
Joined: 05/17/2013

The flickering started ever since I went to a 13.x driver.

I don't play that many games because I do more photoediting and programming than anything else, but every game I played from the simplest of graphics to the more complicated ones, from old games to (relatively) newer ones now create a flickering on the screen.

This only happened when I updated the video driver.

When I first started the process, I only updated the video driver, and attempted to play my games, and noticed the flickering.

I then updated all of my other drivers, and I still had the same problem.

To me, it looks like an issue with the video driver.

 

If there is any information from my machine that you would like to look at for version numbers, let me know.

 

Thanks

 

Doug

 02/19/2014 11:24 PM
User is offline View Users Profile Print this message

Author Icon
MrDimn
Peon

Posts: 7
Joined: 05/17/2013

Eydee - 

 

What software do you recommend that I use to do a video capture of the flickering and who would I send it to?

 

Thanks


Doug

Statistics
84176 users are registered to the AMD Support and Game forum.
There are currently 5 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.