Topic Title: BSOD whenever I install/update drivers
Topic Summary: BSOD atihdw76.sys
Created On: 11/04/2013 10:20 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/04/2013 10:20 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 2
Joined: 11/04/2013

Graphics Card
Sapphire 100312-3SR Radeon HD6950 2gb

AMD Catalyst Driver Version, and Driver History
I've literally spent 12 hours in the last two days installing older and older versions of Catalyst trying to find a working one. The last one that worked prior to initially updating was 13.9. This problem first occurred updating to 13.11 beta v8 for Battlefield 4.

Operating System

Windows 7 x64 Ultimate.

Issue Details
During the install of Catalyst drivers, blue screen of death. Culprit is atihdw76.sys. No matter what I do, what I uninstall, how I boot, as soon as I try and update my freakin drivers I get a BSOD. This started when I tried updating to the latest beta drivers for BF4.


Motherboard or System Make & Model

Power Supply

-Corsair TX CMPSU-750TX 750W

Display Device(s) and Connection(s) Used
-ASUS VW193TR Black 19" LCD connected via HDMI

Applications and Games

-This is just from updating the dang drivers

CPU Details
-AMD Phenom II x4 945 3.0ghz quad-core, stock clock speed

Motherboard BIOS Version
- not sure

System Memory Type & Amount
- G.Skill 2x2gb

Additional Hardware
- Pretty bog-standard Antech case with dual front fans, big top and side fans, standard upper-rear fan. Dual 1tb drives, no SSD.

Additional Details
- Prime95 completed overnight, checked it this morning ran with no errors. HWmonitor and CPU-Z show nothing wrong. Honestly never had any trouble with this system (aside from obviously it's getting old)


So this is freakin infuriating. I'm obviously going to be upgrading this system soon and if I can't work this out quickly I'm going to go intel/nvidia and never touch anything by AMD ever again. My system was working perfectly fine YESTERDAY and when I update to the new drivers (which the people in the EA tech support forums said to do) I suddenly can't boot without uninstalling my graphics card. Now I can't install the last working version and I'm just unable to use the machine basically at all.


Can anyone be a superhero and help me out here? I'd rather not have to by a new machine tomorrow.

 11/05/2013 05:00 AM
User is offline View Users Profile Print this message

Author Icon
Ninja Zombie Killer

Posts: 4905
Joined: 12/27/2008

Doing some research never hurts. There are at least 100 threads about it already. Sometimes come to the forums for information too, not only for complaining.


CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 11/05/2013 01:57 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 2
Joined: 11/04/2013

Look I'm just trying to get my computer running again. I went back 5 pages and didn't see anyone else with the same problem. Literally nobody has posted a BSOD error with this file. This isn't in the 'common problems' sticky either.

So if there's something obvious I'm missing it would awesome if you could help me out.

92819 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.