Topic Title: 13.11 beta Drivers lessen performance?
Topic Summary:
Created On: 11/06/2013 09:54 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/06/2013 09:54 PM
User is offline View Users Profile Print this message

Author Icon
masterx1234
Peon

Posts: 50
Joined: 07/21/2013

ive noticed after upgrading to the new beta drivers, specifically all the 13.11 beta drivers have caused massive framedrops in many games, for instance, the game most affected in my gaming library was crysis 3, now both single player and multiplayer have massive framedrops in certain areas, the fps normally stays at 50-55 fps but now dips down as low as 29 fps, anyone else notice a hit in performance on crysis 3 or is it just me? I measured gpu usage and it seems lower than usual, so is there a workaround, because i do not want to downgrade again because the new beta drivers have actually gotten rid of any and all stutter in my games. so im on the edge trying to decide if i should go back to 13.9, here are my pc specs below

Motherboard: ASUS F2-A55M-LK

Ram: 8GB kingston hyperX predator

Cpu: AMD 6600K Richland APU

Gpu: MSI 7870 OC edition

PSU: corsair cx600

HD: western digital 500GB + 500GB (1 TB total)

cpu cooler: cooler master hyper 212 pro

 

 11/06/2013 10:35 PM
User is offline View Users Profile Print this message

Author Icon
WMudrockJr
Overclocker

Posts: 705
Joined: 04/01/2013

You might want to fill out the Issue Form for the beta 13.11, I have had other Richland users report the same thing. I suggest you drop back to 13.9 drivers, you should notice the difference.



-------------------------

AMD A10-5800K, XFX 7850 Ultra OC Edition 975MHz, 16GB RAM, Win 8.1 Pro 64 bit, MSI 7778 motherboard, 500W PSU, HP P7-1235, CCC 13.12 WHQL

 11/06/2013 11:56 PM
User is offline View Users Profile Print this message

Author Icon
masterx1234
Peon

Posts: 50
Joined: 07/21/2013

im kind of new to this, how do i fill out a report? sorry if im asking a silly question

 11/07/2013 12:55 AM
User is offline View Users Profile Print this message

Author Icon
WMudrockJr
Overclocker

Posts: 705
Joined: 04/01/2013

For future reference the link is normally located at the bottom of the release notes for WHQL or in the case of beta the bottom of the download page.

http://www.amdsurveys.com/se.ashx?s=5A1E27D25AD12B60



-------------------------

AMD A10-5800K, XFX 7850 Ultra OC Edition 975MHz, 16GB RAM, Win 8.1 Pro 64 bit, MSI 7778 motherboard, 500W PSU, HP P7-1235, CCC 13.12 WHQL

 11/07/2013 03:10 AM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4905
Joined: 12/27/2008

Unless you're in the middle if a C3 campaign, I suggest you don't downgrade for the sake of it, just play something else.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 11/07/2013 06:44 AM
User is offline View Users Profile Print this message

Author Icon
BDK
Peon

Posts: 10
Joined: 10/11/2013

Beta1 worked great for me, great performance all around. Beta8 eh not so much. Performance took quite a dip and that's pretty annoying as I was happy with my purchase but now, not so much.

 11/07/2013 10:38 AM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4905
Joined: 12/27/2008

Originally posted by: BDK Beta1 worked great for me, great performance all around. Beta8 eh not so much. Performance took quite a dip and that's pretty annoying as I was happy with my purchase but now, not so much.

 

Well, if you payed for video drivers someone really f....ed you. Go and punch them in the face and demand a refund. Next time use the free download on amd.com.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 11/07/2013 01:08 PM
User is offline View Users Profile Print this message

Author Icon
BDK
Peon

Posts: 10
Joined: 10/11/2013

Originally posted by: Eydee
Originally posted by: BDK Beta1 worked great for me, great performance all around. Beta8 eh not so much. Performance took quite a dip and that's pretty annoying as I was happy with my purchase but now, not so much.

 

 

 

 

Well, if you payed for video drivers someone really f....ed you. Go and punch them in the face and demand a refund. Next time use the free download on amd.com.

 

lol, happy with my purchase of the graphics card .. but not so much after seeing the dip in performance this new driver is giving me.

Statistics
86649 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.