Topic Title: Catalyst 13.9 and 13.4 wont install, Gigabyte R9 290x
Topic Summary:
Created On: 11/08/2013 07:11 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/08/2013 07:11 AM
User is offline View Users Profile Print this message

Author Icon
tomatpaburk
Peon

Posts: 3
Joined: 11/08/2013



Catalyst driver 13.4 and/or 13.9
Fresh system installation Windows 7 64x

Graphics Card: Gigabyte Radeon R9 290x
CPU: Inter(R) Core(TM) i7-4770K CPU 3.50GHz 3.50 GHz
Display Device: BenQ GL2440H on standard VGA graphics adapter
Motherboard: Asus Z87-A
Motherboard Bios: Z87-A-ASUS-1602
System Memory: ADATA DDR3 1600 PC3-12800 8GBx2
Powersupply Corsair TX 750M
Harddrive: Samsung SSD 250gb


I just bought a completly new computer that I built a cupple of days ago, and my problem is that I cant install Catalyst Control Center. It always stops mid installation with the message "Install Package failure".

The message I get in Event Viewer is "Product: AMD Catalyst Install Manager -- Error 1723.There is a problem with this Windows Installer package. A DLL required for this install to complete could not be run. Contact your support personnel or package vendor. Action SetInstallDir, entry: SetInstallDir, library: C:\Windows\Installer\MSIF191.tmp"


Additionally, I cant see the Graphics card in Device Manager, and I cant plug my screen Directly to the graphics card, since then I dont get a signal, I have to plug it to my Motherboard.


Here is a step by step process of what Iv done in my search for a solution.

1. Formatted harddrive and installed fresh Windows 7 64x
2. Installed motherboard drivers that came with the CD
3. Tried to install Catalyst 13.9 (It failed)
4. Allowed Windows to install any and all updates it could find with "Windwos updater", including service pack 1
5. Tried to install Catalyst 13.9 (It failed)
6. Installed .Net 4.5 and C++ manually
7. Tried to install Catalyst 13.9 (It failed)
8. Updated Motherboard BIOS
9. Tried to install Catalyst 13.9 (It failed)
10. Installed Directx9-11
11. Tried to install Catalyst 13.9 (It failed)
12. Tried to install Catalyst 13.4 (Int failed)

Im fresh out of ideas here, why wont it install?

 11/08/2013 07:19 AM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4865
Joined: 12/27/2008

Neither one supports the card so it would be strange if they did install. Why don't you donwload and use the drivers made for your card?

Also as you have a package failure you have a broken windows install as well, so you'd be better off starting with reinstalling that one, then using the correct drivers.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 11/08/2013 07:25 AM
User is offline View Users Profile Print this message

Author Icon
tomatpaburk
Peon

Posts: 3
Joined: 11/08/2013

What do you mean the wrong drivers? The name is 13-9_win7_win8_64_dd_ccc_whql, its the same that comes on the CD with the card.

As for reinstalling windows Iv done that, and it didnt fix the problem. It seems unlikely (although stranger things have happned) that another reinstallation of windows 7 would fix it.

EDIT:
Iv now tried to install the file: amd_catalyst_13.11_betav9.2. That installation finishes but with message:

"Installation complete (warnings occured during installation). View Log for details."

But there is no info in the log it only says success.

But here is the problem. It hasn't installed catalyst............. nothing has changed



Edited: 11/08/2013 at 07:35 AM by tomatpaburk
 11/08/2013 11:41 AM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4865
Joined: 12/27/2008

Don't use express install and you'll see what components it installs. If the display driver is not on the list, there's no reason to proceed.

(And yes, this is indeed a serious design flow in the installer.)



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 11/08/2013 01:02 PM
User is offline View Users Profile Print this message

Author Icon
tomatpaburk
Peon

Posts: 3
Joined: 11/08/2013

I finally found why it wouldnt install catalyst.

The graphic card was not online even thou the fan was spinning. When I connected both of my PCI-E cables to the card it started up.

 11/08/2013 03:07 PM
User is offline View Users Profile Print this message

Author Icon
WMudrockJr
Overclocker

Posts: 705
Joined: 04/01/2013

I real hair puller



-------------------------

AMD A10-5800K, XFX 7850 Ultra OC Edition 975MHz, 16GB RAM, Win 8.1 Pro 64 bit, MSI 7778 motherboard, 500W PSU, HP P7-1235, CCC 13.12 WHQL

Statistics
84849 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.