Topic Title: BF3 very low fps after installing 13.11 beta 9.2
Topic Summary:
Created On: 11/09/2013 01:32 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/09/2013 01:32 AM
User is offline View Users Profile Print this message

Author Icon
masterx1234
Nerfed

Posts: 53
Joined: 07/21/2013

Is anyone else noticing a massive performance drop in battlefield 3 with the new beta drivers? i went from a solid 80-90 fps to 40fps with framedrops all over the place, anyone know of a fix? othrwise im going back to the previous beta drivers

 11/09/2013 07:32 AM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4905
Joined: 12/27/2008

Originally posted by: masterx1234 Is anyone else noticing a massive performance drop in battlefield 3 with the new beta drivers? i went from a solid 80-90 fps to 40fps with framedrops all over the place, anyone know of a fix? othrwise im going back to the previous beta drivers

 

Just go back to whatever worked before and use the beta issue reporting form. When you use a beta, you're supposed to give feedback, that's why betas exist.

http://www.amd.com/betareport



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

Statistics
87625 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.