Topic Title: HD 7970 13.11 Beta 9.2 Battlefied 4 texture flickering
Topic Summary:
Created On: 11/22/2013 12:06 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/22/2013 12:06 PM
User is offline View Users Profile Print this message

Author Icon
Atamasakrator
Peon

Posts: 4
Joined: 11/22/2013

Hello, I'd like to ask if the AMD employees are working on a driver update regarding the problem of far textures flickering especially while playing Battlefield 4. I've just spent over a thousand pounds for a Battlefield 4 ready computer. Would love it to work properly

My specs:

Mobo: Rog Asus Crosshair V Formula-Z
GPU: Rog Asus Radeon HD 7970 Matrix Platinum
CPU: AMD FX 9370
PSU: OCZ FX Series 1250 W 

 11/22/2013 02:20 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Dungeon Master

Posts: 4286
Joined: 12/27/2008

No one seems to have talked about this issue yet. Are you sure it's not just your rig?



-------------------------

CPU: AMD Phenom II X4 810 @ 3250MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 850/1150MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 7 Pro x64

CPU: Pentium 4 Northwood S478 @ 3200MHz | RAM: 1,5GB DDR 400| MoBo: Gigabyte GA-8S661FXMP-RZ | GPU: ASUS Radeon X1650 Pro 256MB | Display: Dimarson 19" CRT | PSU: Noname 400W | OS: changing twice every week...

 11/22/2013 02:26 PM
User is offline View Users Profile Print this message

Author Icon
Atamasakrator
Peon

Posts: 4
Joined: 11/22/2013

I used nVidia cards before and I am new to Radeons. Never had that problem before. I am also new to these forums, but on other forums they say it's a problem of drivers.

 11/22/2013 04:32 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Stack Smasher

Posts: 6102
Joined: 11/13/2009

Since you are new to AMD...the CCC graphics settings are probably new to you as well. Try these settings as a starting point.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit *Gateway HD2401 24" 2ms 1920x1200  ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit  



* A clear conscience is usually a sign of bad memory *

 11/23/2013 09:33 AM
User is offline View Users Profile Print this message

Author Icon
gr8sho
Peon

Posts: 5
Joined: 11/23/2013

Originally posted by: Atamasakrator Hello, I'd like to ask if the AMD employees are working on a driver update regarding the problem of far textures flickering especially while playing Battlefield 4. I've just spent over a thousand pounds for a Battlefield 4 ready computer. Would love it to work properly

What caught my eye in this thread was the term " far textures flickering".  I am seeing this playing Skyrim.  For instance, in any area where you see a large expanse of water.

I applied the recommend setting posted above, but didn't make any difference.



-------------------------

Crosshair V Formula, AMD FX 8350 @4.8GHz, Radeon HD 7970 DiamondMM CrossFireX,  CoolerMaster 1200W SilentProGold, GSkill TridentX 2400MHz (2x8GB)

 11/23/2013 01:15 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Dungeon Master

Posts: 4286
Joined: 12/27/2008

Someone should make a video, so others can compate. Maybe it's just consolitis, not a driver issue. An AMD vs nvidia frame-by-frame comparison would be the best.



-------------------------

CPU: AMD Phenom II X4 810 @ 3250MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 850/1150MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 7 Pro x64

CPU: Pentium 4 Northwood S478 @ 3200MHz | RAM: 1,5GB DDR 400| MoBo: Gigabyte GA-8S661FXMP-RZ | GPU: ASUS Radeon X1650 Pro 256MB | Display: Dimarson 19" CRT | PSU: Noname 400W | OS: changing twice every week...

 11/23/2013 07:18 PM
User is offline View Users Profile Print this message

Author Icon
gr8sho
Peon

Posts: 5
Joined: 11/23/2013

Originally posted by: Eydee Someone should make a video, so others can compate. Maybe it's just consolitis, not a driver issue. An AMD vs nvidia frame-by-frame comparison would be the best.

Just because you don't see it doesn't mean the issue report is false. 

If one of the developers asks, I will take the time to create the video. 

I personally have experience with ATI cards, 5950, 800XL, X1650GT, X1900GT.  Also had Nvidia GTX 460s in SLI.

I would rather see some more suggestions on how to solve the problem.  It's appalling two 7970s in XfireX should have this sort of problem.

BTW, I may rip the current beta drivers out completely and reinstall again clean just to try that out.  The problem with using AMDs driver uninstall utility is that it has left my machine in a vegetable state when it removes the USB Filter driver, as my USB mouse and keyboard become inoperative.



-------------------------

Crosshair V Formula, AMD FX 8350 @4.8GHz, Radeon HD 7970 DiamondMM CrossFireX,  CoolerMaster 1200W SilentProGold, GSkill TridentX 2400MHz (2x8GB)

 11/23/2013 07:37 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Dungeon Master

Posts: 4286
Joined: 12/27/2008

It's not about being false. It's about "flickering" can mean 100000 things. You can also write a 2000-page essay about it to describe it properly, but hitting the Fraps record button is easier. Well, for someone who is not that lazy.

If you need to talk to developers, contact AMD. This is a community forum, you won't find any developers here.



-------------------------

CPU: AMD Phenom II X4 810 @ 3250MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 850/1150MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 7 Pro x64

CPU: Pentium 4 Northwood S478 @ 3200MHz | RAM: 1,5GB DDR 400| MoBo: Gigabyte GA-8S661FXMP-RZ | GPU: ASUS Radeon X1650 Pro 256MB | Display: Dimarson 19" CRT | PSU: Noname 400W | OS: changing twice every week...

 11/24/2013 03:54 AM
User is offline View Users Profile Print this message

Author Icon
Atamasakrator
Peon

Posts: 4
Joined: 11/22/2013

Stumped's settings didn't help. I have actually installed latest beta driver and latest GPU Tweak and game runs generally more stable but flickering is still there, I will try to FRAPS it today.

 11/24/2013 04:58 AM
User is offline View Users Profile Print this message

Author Icon
Atamasakrator
Peon

Posts: 4
Joined: 11/22/2013

Ok, check this out.. It appears that those flickers happen on destructible objects mostly. So I wonder if it's AMD driver fault or guys at DICE.

 

https://www.facebook.com/photo.php?v=616348488426922&l=2232333991922806337

Statistics
81026 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.