Topic Title: AMD driver crashes on new rig with Windows 7 64bit
Topic Summary: A very new rig with Windows 7. Gaming impossible
Created On: 11/22/2013 12:42 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/22/2013 12:42 PM
User is offline View Users Profile Print this message

Author Icon
LinkeHarryB
Peon

Posts: 1
Joined: 11/22/2013

Since I built my new rig it works fine for everything except games. I continually get the error message "AMD display driver stopped responding and has recovered". I'm running everything with the latest drivers. I tried reinstalling the AMD driver (13.11 beta 9.2) and going back to the boxed driver (13.6) that came with the videocard. I also tried running the games on low settings and some other tricks learned from this forum. Nothing seems to work. I'm quite desperate as I spent a lot of money on this rig and some games which are now utterly unplayable. Anyone has any idea on what I can do?

 

System specs:

MB: ASUS Z87-C

CPU: intel core i5 4670K (not overclocked yet)

RAM: 8 gb DDR 3 1600 MHz

PSU: Corsair 750W

Videocard: Sapphire R9 280X 3GB GDDR5 OC Dual-X

OS: Windows 7 ultimate 64 bit

 

 11/22/2013 01:17 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7064
Joined: 11/13/2009

Try the TDR fix in the FAQ section.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

 11/22/2013 06:42 PM
User is offline View Users Profile Print this message

Author Icon
gruia
Nerfed

Posts: 68
Joined: 10/31/2013

do you use DDU to uninstall drivers?

for me restarting Bios did the trick. Drivers are a mess , just try random versions or look at the Saphire website, they should provide a working version. (that was my case with MSI)

Statistics
84264 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.