Topic Title: AMD Catalysttm 13.11 Beta 9.5 Driver for Windows®
Topic Summary:
Created On: 12/03/2013 03:52 PM
Status: Post and Reply
Linear : Threading : Single : Branch
1 2 Next Last unread
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 12/03/2013 03:52 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7094
Joined: 11/13/2009

Feature Highlights of The AMD Catalyst 13.11 Beta9.5 Driver for Windows

  • Includes all Feature Highlights of The AMD Catalyst 13.11 Beta9.4 Driver
  • Resolves the issue of AMD Overdrive missing in the AMD Catalyst Control Center for the AMD Radeon R9 290 Series graphics cards
  • Resolves intermittent flickering seen on some AMD Radeon R9 270x graphics cards
  • Resolves graphics corruption seen in Starcraft®
  • Improves frace pacing r?esults in AMD Quad CrossFire configurations for the following: Hitman: Absolution, and Total War?: Rome 2

http://support.amd.com/en-us/kb-articles/Pages/latest-catalyst-windows-beta.aspx



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

 12/03/2013 06:42 PM
User is offline View Users Profile Print this message

Author Icon
Edifier
Peon

Posts: 8
Joined: 11/25/2013

Still got flickering (XFX 280X-TDFD). Come on AMD, the problem isn't only with 270X..

 12/03/2013 07:45 PM
User is offline View Users Profile Print this message

Author Icon
Marty2Life
Peon

Posts: 6
Joined: 11/01/2013

Resolves graphics corruption seen in Starcraft®

 

I checked for this. Plain 256Color (8Bit Screen) Games in Windows x64 with 7850 ...

i have only Updated the Driver via Device Manager and Installed CCC

Manually to adjust the GPU Scale Option

[x] Akte Europa

[x] BioSys

[x] Command & Conquer: Red Alert 1

[x] Command & Conquer 1: Tiberian Dawn

[x] Cybermercs v1.33

[x] Enemy Engadget

[x] Dark Reign 1 inc Addon

[x] StarCraft inc Broodwar

[x] Windows Desktop Resolution in 8Bit  (With Ati Tray Tools )

[x] FlightSims (Janes etc...)

[x] Final Demand

[...] and other Pure Windows 256 Color Games

Looks very good 8Bit Screen Repaired, thanks ATI/AMD Developer

[X]= Worked/ [-]..nop



Edited: 12/03/2013 at 09:35 PM by Marty2Life
 12/03/2013 10:24 PM
User is offline View Users Profile Print this message

Author Icon
ashleylai87
Peon

Posts: 29
Joined: 11/26/2013

Originally posted by: Edifier Still got flickering (XFX 280X-TDFD). Come on AMD, the problem isn't only with 270X..

 



Indeed, this issue happens with 7790 / R7 260X as well. -.- Being reporting the issue since 13.11 beta 6 ..........

 12/04/2013 08:39 AM
User is offline View Users Profile Print this message

Author Icon
shoker
Peon

Posts: 5
Joined: 12/04/2013

Same problem with MSI R9 270X Gaming 2G.....flickering/flash monitor every 5 minutes....or up auto clock

bad card  D:

I have 9.5 beta driver!

 12/05/2013 02:59 AM
User is offline View Users Profile Print this message

Author Icon
VWM
Peon

Posts: 29
Joined: 12/05/2013

I have Gigabyte GV-R927XOC-2GD and also after driver update 13.11 beta9,5 my screen sometime flickers.

And is my second problem also related with new drivers? When my PC is in idle, after screen turns off ( under power manager I have set after 15 min. my screen turns off ) , ccc.exe catalys control centre: host application rise my cpu activiti and temp rises. ( sometimes 2 cores, sometime 4 core activity rise up to 30 %). Someone also are noticed that?

 



-------------------------

CPU: AMD FX-8350 (black edition FD8350FRHKBOOX) + Cooler Master Hyper 212 X Army (push/pull config. fans Enermax T.B.Silence UCTB12P) / MOBO: Asus M5A99FX Pro2.0 / GPU: Gigabyte Amd Radeon R9 279x ( GV-R927XOC-2D ) / RAM: Kingston HyperX 2x4GB DDR3 1600Mhz / SSD: Samsung Evo 840 250Gb / Case: Coolermaster K280 / PSU: Chieftec Smart Series GPS-600A8

 12/05/2013 05:20 AM
User is offline View Users Profile Print this message

Author Icon
Uns33n
Peon

Posts: 24
Joined: 02/22/2009

Originally posted by: Edifier Still got flickering (XFX 280X-TDFD). Come on AMD, the problem isn't only with 270X..

 

Damn I was going to try and install beta 9.5 to check if flickering has gone for R9 280x series. So, you checked and flickering is still present?

 12/05/2013 01:14 PM
User is offline View Users Profile Print this message

Author Icon
P_Dub_S
Peon

Posts: 6
Joined: 01/27/2010

These drivers are still broken for my 6970's when playing League of Legends vsync is broken and there are serious frame pacing problems. Hitching when moving and graphic coruption on the skills UI.

 12/05/2013 03:45 PM
User is offline View Users Profile Print this message

Author Icon
gnazar
Peon

Posts: 1
Joined: 12/05/2013

I have an MSI R9 270X Gaming, and my screen is still flickering with this latest driver -_- . Very annoying, needs to be fixed asap. 

 12/05/2013 03:55 PM
User is offline View Users Profile Print this message

Author Icon
Edifier
Peon

Posts: 8
Joined: 11/25/2013

Originally posted by: Uns33n
Originally posted by: Edifier Still got flickering (XFX 280X-TDFD). Come on AMD, the problem isn't only with 270X..

 

 

 

 

Damn I was going to try and install beta 9.5 to check if flickering has gone for R9 280x series. So, you checked and flickering is still present?

 

Yeah, the flickering is still there. I've tried different drivers (including 13.9, 13.10, 13.11 WHQL) and the problem still happens with all of them. I opened a ticket at xfx support, but it has been one week and they didn't even answered..

 12/05/2013 09:14 PM
User is offline View Users Profile Print this message

Author Icon
Sysnets
Peon

Posts: 9
Joined: 11/19/2013

Originally posted by: Edifier Still got flickering (XFX 280X-TDFD). Come on AMD, the problem isn't only with 270X..

 

 

It's happen on my HIS 7790 with 13.9 driver

 12/05/2013 10:12 PM
User is offline View Users Profile Print this message

Author Icon
Uns33n
Peon

Posts: 24
Joined: 02/22/2009

Originally posted by: Edifier
Originally posted by: Uns33n
Originally posted by: Edifier Still got flickering (XFX 280X-TDFD). Come on AMD, the problem isn't only with 270X..

 

 

 

   

 

 

 

 

Damn [IMG][/IMG] I was going to try and install beta 9.5 to check if flickering has gone for R9 280x series. So, you checked and flickering is still present?

 

 

 

 

Yeah, the flickering is still there. I've tried different drivers (including 13.9, 13.10, 13.11 WHQL) and the problem still happens with all of them. I opened a ticket at xfx support, but it has been one week and they didn't even answered..

 

This is not good at all It means the flickering with R9 270x is still present even though release notes mention it as solved! Seems I'll just wait till they release a stable release. Don't know when that might be.

 12/07/2013 05:11 AM
User is offline View Users Profile Print this message

Author Icon
Destroyer99
Peon

Posts: 8
Joined: 11/22/2013

Been working flawless on my Sapphire 290. No crashes or black screens thus far. Glad OverDrive was restored, too.



-------------------------

i5 2500K @ 4.4GHz | Gigabyte P67A-UD4-B3 | 12GB Corsair Vengeance 1600MHz | Sapphire R9 290 | Corsair TX 650w | Mushkin Chronos Deluxe MX 120GB SSD | Creative X-Fi Titanium Fatal1ty | ASUS 23" 1080p | Windows 8.1 Enterprise 64-bit



Edited: 12/07/2013 at 06:37 AM by Destroyer99
 12/08/2013 01:41 AM
User is offline View Users Profile Print this message

Author Icon
rexii
Peon

Posts: 3
Joined: 12/07/2013

I lost my Crossfire option when I upgraded to this from 13.9. However the performance in certain games has increased, though I still want my crossfire option to come back.

 

x2 6950 2GB on Windows 7 64bit

 

I've tried everything in terms of clean reinstalls - nothing.

 12/09/2013 04:38 AM
User is offline View Users Profile Print this message

Author Icon
lkiommmmzzzz
Peon

Posts: 9
Joined: 12/07/2013

7790 installed this beta driver stability you

 

 12/09/2013 06:21 AM
User is offline View Users Profile Print this message

Author Icon
Calavera84
Peon

Posts: 5
Joined: 12/09/2013

Hello everyone, I have a radeon r9 290 driver and catalyst 13:11 v beta 9.5.Impostando frequency of 144hz monitor the ram vga traveling at 1250MHz at idle and fixed with browsers and programs chiusi.Cambiando frequency of 60Hz or 120Hz monitor ram down to 150MHz as it should. We hope that solve the problem in the next driver, I would use the monitor to 144hz

 12/09/2013 11:40 AM
User is offline View Users Profile Print this message

Author Icon
Viking2121
Peon

Posts: 2
Joined: 12/09/2013

Hello, I have 2x 5850's and I run Windows 8 64bit, The 13.11 beta 9.5 driver will hang the system if powerplay is enabled, Its done this witht he beta 9.2 as well. But not with 13.10 or 13.9, even cleaned the old drivers from the system. Windows 7 with any of the 13.11 beta drivers I can run just fine with powerplay.

 

When the system hangs, The screen will freeze but I can still move the mouse, and hear my friends over Teamspeak, and I can talk back to them, but the mouse and keyboard's inputs are unresponsive, I have to hit the reset button.

 

Disabling powerplay as I said fixed it, but forces the cards to run in 3d clocks, not a big problem, but makes the fans jump all over the place.

 

Specs:

OS: Windows 7/Windows 8 64bit

CPU: AMD Phenom II x6 1100T 4.4ghz (3000mhz CPU-NB)

MOBO: ASRock 990FX Fatality Pro

RAM: 16GB Corsair Vengence DDR3 1600mhz

VIDEO: 2x HD5850's (with 5870 bios, 1012mhz core 1230mhz mem) HD6450 for dual monitors (5850 dual monitor flicker bug)

HDD: 7TB total

PSU: Corsair GS700

 12/09/2013 02:36 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4851
Joined: 12/27/2008

 

Originally posted by: Viking2121 Hello, I have 2x 5850's and I run Windows 8 64bit, The 13.11 beta 9.5 driver will hang the system if powerplay is enabled, Its done this witht he beta 9.2 as well. But not with 13.10 or 13.9, even cleaned the old drivers from the system. Windows 7 with any of the 13.11 beta drivers I can run just fine with powerplay.

When the system hangs, The screen will freeze but I can still move the mouse, and hear my friends over Teamspeak, and I can talk back to them, but the mouse and keyboard's inputs are unresponsive, I have to hit the reset button.

Disabling powerplay as I said fixed it, but forces the cards to run in 3d clocks, not a big problem, but makes the fans jump all over the place.

Specs:

OS: Windows 7/Windows 8 64bit

CPU: AMD Phenom II x6 1100T 4.4ghz (3000mhz CPU-NB)

MOBO: ASRock 990FX Fatality Pro

RAM: 16GB Corsair Vengence DDR3 1600mhz

VIDEO: 2x HD5850's (with 5870 bios, 1012mhz core 1230mhz mem) HD6450 for dual monitors (5850 dual monitor flicker bug)

HDD: 7TB total

PSU: Corsair GS700

Might be some magical tablet power saving feature of 8 not playing nice with the drivers. You may report the issue to AMD, though not using a tablet OS would be a more clever solution.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 12/09/2013 07:30 PM
User is offline View Users Profile Print this message

Author Icon
Viking2121
Peon

Posts: 2
Joined: 12/09/2013

More Clever? Not really, Windows 8 is much faster, things just work, while Windows 7 with a few apps, it just refuses to work right (older apps). Install the Classic Shell, I'd take windows 8 anyday over Win 7.

 

I'm asking help or maybe work around with this driver, not asking if I shouldn't be using Win 8. Plus BF4 plays sooo much smoother under Windows 8 compared to Windows 7, Don't think thats a driver issue, more like EA not knowing how to properly relase a game without major flaws.

I love my 5850's, Plays BF4 Ultra without AA vary well, Still get random lock ups, and Display driver has stopped responding issue, even when both cards are at stock 5850 values, I get issues with Flash (steam store on both windows 7 and windows 8 with powerplay disabled on the 13.11 beta drivers, with powerplay, flash does not crash (again, cards at stock values) But in windows 8 it will hang with powerplay. 13.10 never had an issue, 13.9 never had an issue, 13.4 was did not work right with crossfire under windows 7, but windows 8 it was fine.

 

To me that sounds more like an issue with the 13.11 beta drivers, Its beta I understand, but 13.12 needs to hurry up lol. Windows 8 isn't to blame here, Its the 13.11 driver for whatever reason not liking my setup. again BF4 is unplayable under windows 7 20 - 30fps, but Windows 8 I can play ultra at 60fps and not move from 60.

Instead of recommending not to use a product, my suggestion would be to help if your willing to reply, this isn't a fan boy fourm, if I wanted that, I can go to Overclock(dot)net and listen to all of them over there.Sorry for the rant, But I did not see your post worth 10 cents of my time with that kind of reply.

 12/17/2013 07:14 AM
User is offline View Users Profile Print this message

Author Icon
Ragnador
Peon

Posts: 11
Joined: 09/04/2013

Powercolor Radeon HD7870 PCS+ VortexII , Asus HD 6950 DCII (different systems)

Still flickering issue in Windows (64-bit 8.0 & 8.1) especially while using google chrome.

No flickering in Games.

 

 

-----------------------------------------------------------------------

You all pls dont forget to use:

http://www.amd.com/betareport

 

                                                                                                          

-----------------------------------------------------------------------



Edited: 12/17/2013 at 07:34 AM by Ragnador
Statistics
84352 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.