Topic Title: Cant install 7870 on new system(z87/4670k)
Topic Summary: Trying to move gfx card from old system, cant get install to work
Created On: 12/15/2013 12:18 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 12/15/2013 12:18 PM
User is offline View Users Profile Print this message

Author Icon
cybersimian
Peon

Posts: 1
Joined: 12/15/2013

Hi, I am having a nightmare time trying to install my graphics card into my new system. The card was working fine in my old Q6600 system but whnever I try to install it onto my new system it crashes/freezes.

 

I have tried several methods of installing so far;

 

Scenario 1:

 

Built the system including the gfx card, tried to install win8 pro. Installation was hanging at setting up devices 30%. Physically removed card, windows installed fine.

 

Scenarion 2:

 

Fitted the card with widows already installed and updated to 8.1 and tried to use driver auto update. System is fine when treating the card as a generic display driver but crashes during catalyst install then will not boot into windows until drivers have been uninstalled(some attempts I had to physically remove th card as well even though I was outputting through the onboard gfx).

 

scenario 3:

 

Fitted the card and used it as generic adaptor to download and extract but not install catalyst suite. Restarted in safe mode and installed driver through device manager. System crashes whilst booting(win logo shows for a second then screen resizes and goes completely black, can hear a windows "bing" if i hit escape so system is still runnig in background. Again I need to uninstall drivers completely to boot even using a different display adapter.

 

scenario 4:

 

Started in low res mode and tried to install drivers through device manager. Results in instant black screen and again Pc wont boot until drivers have been removed.

 

 

I noticed on later attempts that thers is a vertical band of discolouring a couple of inches wide when using the card as geberic adapter, this persists into the bios settings screen afer restarting.

 

 

 

Graphics Card

78780 MSI 2Gb twin Frozr edition

 

AMD Catalyst Driver Version, and Driver History

 

Mostly been trying 13-9, no history, problems occur even during win install with default drivers

 

Operating System

win 8 and 8.1 pro (64 bit)

 


Motherboard or System Make & Model

 

Asrock Z87 Pro 4


Power Supply

 

Corsair builder 650W

 

Display Device(s) and Connection(s) Used

Evotel HDTV/monitor used HDMI and VGA cables

 


Applications and Games

 

Just windows


CPU Details

 

I5 4670K


Motherboard BIOS Version

 

 

Tried default Asrock bios, ran UEFI auto update this morning after running into issues

 

System Memory Type & Amount

 

 

2 x 4 GB Gskill ripjaws CL9

 

Additional Hardware

 

Booting from 128 Gb SSD, no other hardware unattached.

 

Steps taken

 

other than those above I have tried using the other PCIe slot but this had no effect. nor did manually setting the PCIe generation in BIOS

 

It will be a week before I can test the card in another system as I have moved, likewise I also do not have a spare GFX card here to test the new system(though it is working fine with onboard GFX.

 

Any help or guidance woud be greatly appreciated!

Statistics
84866 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.