Topic Title: Gigabyte R9 270X, 13.11 Beta v9.5, can't use more than 2 Displays!?
Topic Summary:
Created On: 12/15/2013 01:56 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 12/15/2013 01:56 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 9
Joined: 04/09/2009

I just built my brother a new computer, see stats for details if necessary:

Asus Sabertooth 990FX R2.0
2x4 GB Crucial Dual Channel Memory
OCZ 650 Watt PSU
Gigabyte R9 270X GPU
Windows 7 Ultimate x64 

So, after building the computer and installing windows and the catalyst beta, all 3 monitors functioned normally. 2 Were 20 inch Acer's with the Acer minitor drivers for them from Windows Update. The 3rd is a 55 inch LG tv with no drivers but worked perfectly fine anyway.

I told him I had a spare 22 inch Acer monitor to switch out with one of the 20 inch ones if he preferred for playing BF4 and he agreed. ALL WE DID was switch the 2 monitors, no catalyst changes, no driver changes, no computer restarts, nothing, and now it says we can only run 2 monitors and we have to exchange the new monitor with one of the other 2. It runs any 2 at a time just fine, just not all 3 at once.

We're using the 2 Monitors with the DVI ports and the TV through the HDMI port. Not using the DP port. I'm very familiar with the DP active/passive issue, that's not it, and that's all anyone seems to answer for other people having similar problems.

I uninstalled the beta, ran driver sweeper, then ccleaner registry cleaner to wipe all traces then reinstalled, no change.
I got the acer 22 inch monitor drivers from windows update, no change.
I switched the 22 inch for the original 20 inch, no change.

I even tried creating a new preset in Catalyst then modifying it in notepad with the 3rd monitor's hardware ID, correct Location, color settings and screen resolution then activating it. It seemed to work for a second and displayed all 3 in the correct order and positions, but it displayed the 3rd monitor number as "-1" and not "3" and quickly reverted to 2 monitors again.

So what the HELL could cause a problem like this!? I've dealt with plenty of Catalyst problems over the years and I've never seen a card refuse to run another monitor before. I even have 2 crossfired Gigabyte 7850's in my own computer running three 27 inch monitors and an identical LG 55 inch tv to his all the time, working just fine with the same beta driver.

Also, the entire purpose of building this new computer at the moment is to run Battlefield 4, so the beta driver is kind of a necessity. Please don't bother telling me to try older driver versions. It's also used for work and playing movies/tv shows from our media server, usually all at the same time. Running at least 3 monitors is crucial.

93400 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.