Topic Title: XFX HD 7970GHz Displayer Driver Stopping
Topic Summary: 7970 unable to play games.
Created On: 12/21/2013 10:20 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 12/21/2013 10:20 PM
User is offline View Users Profile Print this message

Author Icon
subrand0m
Peon

Posts: 4
Joined: 12/21/2013

So I have been fighting with this for 5 days, it has cost me over $200 (kinda needed to upgrade the Mobo anyways)

 

Clean install windows 7, Fully updated ( took 3+ hours )

Installed 13.12 CCC

Basic usage, facebook, watching videos, netflix, hulu, crunchyroll, is Flawless

Load a video game, No go, game launches, then just Driver crashes after a few moments, I have followed every guide I could find to look for a way to fix this. I am simply at a loss.

http://pastebin.com/kBHpJGf2 <- DxDiag

Here is a full Dxdiag of my pc but a quick rundown below

 

  • Asrock z77 Extreme 4
  • Intel i7 3770k
  • 16 gigs G'skill (2x8gb)
  • XFX 7970 BE Ghz edition
  • 750 watt Coolermaster PSU
for the full info check out the pastebin.

 



Edited: 12/22/2013 at 09:22 PM by subrand0m
 12/22/2013 09:23 PM
User is offline View Users Profile Print this message

Author Icon
subrand0m
Peon

Posts: 4
Joined: 12/21/2013

I see nearly 50 views on this post, no one has any ideas?

 12/22/2013 09:36 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7078
Joined: 11/13/2009

When in Device Manager..is your card recognized?



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

 12/23/2013 08:15 AM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4849
Joined: 12/27/2008

If I understand correctly, you already had the card, had no issues, then 5 days before the OP you replaced the motherboard, and driver crashes started happening. Is that correct? I don't think it's a coincidence. Contact the motherboard manufacturer, explain the situation, ask for a BIOS update that solves the problem.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 12/23/2013 11:48 AM
User is offline View Users Profile Print this message

Author Icon
subrand0m
Peon

Posts: 4
Joined: 12/21/2013

Officaly what happened, I owned the card, the front fan stopped worked causing the temp to rise, I got a replacment, after getting the replacement my system would just not work, Could not even post this replay I am doing now.

Ordered a new motherboard, set it up, still getting the Driver crashing, but I am able to use the pc for everything but games. I am thinking the swap between 2d and 3d is the issue. Or the issue is in the boosting system. Under full load the driver does not crash. But while loading up games the speed jumps from 500 - 1000 a few times resulting in what I am guessing is the crash.

Statistics
84315 users are registered to the AMD Support and Game forum.
There are currently 6 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.