Topic Title: Can't install AMD driver for HD 7950
Topic Summary:
Created On: 12/24/2013 04:57 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 12/24/2013 04:57 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 2
Joined: 12/24/2013

Graphics Card
 Club3D HD 7950 RoyalKing

AMD Catalyst Driver Version, and Driver History
Default Windows drivers at the moment. Tested the following:
- 13.12
- 13.11 beta 9.5
- 13.9
- 13.4
- 13.1

Operating System
Windows 8.1 64 bit

Issue Details
First driver 13.4 got a couple of BSODs (SYSTEM_SERVICE_EXCEPTION 0x3B)
Then I decided to install the latest version, 13.12. I got a BSOD during the installation of the driver: the screen goes black twice. Then it goes black another time, I hear the sound Windows makes when disconnecting hardware, my screen dims, and then I get another BSOD (SYSTEM_THREAD_NOT_HANDLED_M 0x1000007E). Both BSODs are caused by atikmpag.sys.

I've tried the versions listed above. Anything newer than 13.4 fails to install. 13.4 and below do install, but I get BSODs the next day.
The only thing that seems to work is the default driver from Windows. I also noticed that atikmpag.sys won't uninstall, unless I do it manually. If the PC is running on the default Windows driver, but when atikmpag.sys is not properly uninstalled, atikmpag.sys still causes BSODs.

I've also tried manually installing drivers. But this gives the exact same BSODs.

In this Dropbox folder you can find a couple of minidumps. Both SYSTEM_SERVICE_EXCEPTION and SYSTEM_THREAD_NOT_HANDLED_M 0x1000007E.

Here are also pictures from CPU-Z:

Motherboard or System Make & Model
ASRock z77 pro4-m

Power Supply
XFX Pro 550 W

Display Device(s) and Connection(s) Used
LG W2361V connected with DVI

CPU Details
Intel i5 3570K

Motherboard BIOS Version
ASRock BIOS 2.00

System Memory Type & Amount
- Kingston HyperX 1333MHz 2 x 8 GB

Additional Hardware
- Crucial m4 128GB boot drive
- Seagate Barracuda 1TB data drive
- 3 case fans

Additional Details
- Did a virus scan with Windows Defender. I also ran Malwarebytes, Spybot and Super Anti Spyware. Nothing found.
- I've reseated the graphics card, reconnected the power connectors. Checked my RAM with Memtest86. I also tried using just one stick of RAM and in different slots. No errors.
Prime95 didn't report any errors either.

Edited: 12/24/2013 at 05:26 PM by Saticmotion
 12/24/2013 08:04 PM
User is offline View Users Profile Print this message

Author Icon
Ninja Zombie Killer

Posts: 4905
Joined: 12/27/2008

Any hacktivations, watermark removals, custom boot logos, system components changed with dism etc.?


CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 12/25/2013 08:43 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 2
Joined: 12/24/2013

None of that at all...

It seems like I'm getting somewhere now. Installed a new Win8 partition, and the driver seems to be working fine there. Some more stress testing, and if it proves to be stable, I'll wipe my main drive and start with a clean Win8.

 12/26/2013 08:46 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 8
Joined: 12/26/2013

With Windows 8.1, 13.9 is stable for me, but I installed 13.9 prior to upgrading to 8.1 (IE I installed it when I installed Windows 8, then when I installed 8.1 it automatically rolled over and hasn't crashed... yet)

You should be ok to wipe your partition and upgrade 8 to 8.1 with 13.9, but I don't recommend 13.12 as from what I've seen, it causes a fair amount of BSOD's with 8.1, regardless of system setup/graphics card.

If it makes a difference, I'm running a 2gb HIS IceQ 7850.


Hope this helps


93111 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.