Topic Title: Catalyst 13.12 Drivers lags in games
Topic Summary:
Created On: 12/29/2013 04:09 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 12/29/2013 04:09 PM
User is offline View Users Profile Print this message

Author Icon
Al Krimson
Peon

Posts: 2
Joined: 12/29/2013

I have installed Catalyst 13.12 Drivers on my Ati Radeon HD 5770 1Gb and lags appears in Amnesia: The Dark Descent. I've played it yesterday and no lags were. It not lags like slower PC, but it like 1 sec freezes. Settings in the game the same, no running applications, only Amnesia: The Dark Descent and Steam. Latest drivers which was good were 13.11, but i can't find where i can download it. Will AMD.com have archive of old drivers?

 12/30/2013 08:56 AM
User is offline View Users Profile Print this message

Author Icon
Hardwood
Dungeon Master

Posts: 4021
Joined: 01/27/2008

Don't know what OS you have but you can try here:
http://support.amd.com/en-us/download/desktop/previous?os=Windows+7+-+32

 

FWIW, had 13.12 on my 5870 and Far Cry 3 started green screening on me. Went back to trusty old 12.10 and no issues.



-------------------------

#1: Phenom II C2 955BE @ 3.6, Antec Kuhler 920, Gigabyte GA-MA790FX-DS5, Asus 5870/V2, ASUS Xonar D2X, 4 x 1gig OCZ2N1066SR2GK @800, Antec Truepower New 750, Arc Midi, Win8.1pro x64
#2: MSI A88X-G45, AMD A10-7850K, IGP, AMD 2x4GB 2133 (R938G2130UK), Antec 750 True, 128GB Sandisk SSD, WD Black 1TB, Win8.1pro x64
#3: Athlon 64 X2 4200+, AGP 1950pro, Audigy 2, Asus A8V-D, 2gig ram, Enermax 465P, Antec900case. Now on Win8.1pro cat 10.2

 12/30/2013 10:18 AM
User is offline View Users Profile Print this message

Author Icon
Al Krimson
Peon

Posts: 2
Joined: 12/29/2013

Intel Core 2 Duo E8400@3.0 GHz/6 Gb RAM/Sapphire Radeon HD 5770 1Gb/Windows 7 x64/Catalyst 13.12

 

By the way, where download link in link you provided? http://support.amd.com/en-us/download/desktop/previous?os=Windows+7+-+32 I can't find it. I only can download .Net Framework 4



Edited: 12/30/2013 at 10:27 AM by Al Krimson
 12/30/2013 03:35 PM
User is offline View Users Profile Print this message

Author Icon
Dch48
Nerfed

Posts: 68
Joined: 09/15/2011

In my case, the latest driver I can use that works completely as it should is 13.4. I did mange to install 13.12 but it didn't look or perform as well as 13.4 so I reverted back. 13.4 seems to be a very good driver for 6000 series and below cards. Especially in a single card setup.

As you say, 12.10 was also very good.



-------------------------
HP Dv6-6140us Laptop, AMD A8-3500M APU with Radeon HD 6620G graphics, 6 GB DDR3-1333 RAM.
 12/30/2013 06:02 PM
User is offline View Users Profile Print this message

Author Icon
T0x1cx
Peon

Posts: 1
Joined: 12/30/2013

After I installed the latest version of the catalyst, while I'm playing games that do not use much the video card, which usually run games at 120 fps, after upgrading the games at times the fps drops to 10.

i have xfx HD7850.

 12/31/2013 10:09 AM
User is offline View Users Profile Print this message

Author Icon
Hardwood
Dungeon Master

Posts: 4021
Joined: 01/27/2008

By the way, where download link in link you provided? http://support.amd.com/en-us/download/desktop/previous?os=Windows+7+-+32 I can't find it. I only can download .Net Framework 4

The link works here in N america Al. Just try googling "AMD PREVIOUS DRIVERS". Maybe there's a different site for your country.



-------------------------

#1: Phenom II C2 955BE @ 3.6, Antec Kuhler 920, Gigabyte GA-MA790FX-DS5, Asus 5870/V2, ASUS Xonar D2X, 4 x 1gig OCZ2N1066SR2GK @800, Antec Truepower New 750, Arc Midi, Win8.1pro x64
#2: MSI A88X-G45, AMD A10-7850K, IGP, AMD 2x4GB 2133 (R938G2130UK), Antec 750 True, 128GB Sandisk SSD, WD Black 1TB, Win8.1pro x64
#3: Athlon 64 X2 4200+, AGP 1950pro, Audigy 2, Asus A8V-D, 2gig ram, Enermax 465P, Antec900case. Now on Win8.1pro cat 10.2

 12/31/2013 02:28 PM
User is offline View Users Profile Print this message

Author Icon
black_zion
80 Column Mind

Posts: 12471
Joined: 04/17/2008

FileHippo has an archive of all previous driver releases.

-------------------------
ASUS Sabertooth 990FX/Gen3 R2, FX-8350 w/ Corsair H60, 8 GiB G.SKILL RipjawsX DDR3-2133, XFX HD 7970 Ghz, 512GB Vertex 4, 256GB Vector, 240GB Agility 3, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, HP ZR2440w, Win 7 Ultimate x64
 01/07/2014 08:52 PM
User is offline View Users Profile Print this message

Author Icon
cRowSn
Peon

Posts: 12
Joined: 12/26/2013

yea go with older drivers. had the same issue with 13.11 and 12.now im back to default; i think mine was released in september



-------------------------
Asus m5a78l-m le / AMD FX-6100 @ 3,3Ghz / Sapphire R9 270X 2GDDR5 / 8GB DDR3 @ 1333MHz / Win7 HP 64Bit /
Statistics
85422 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.