Topic Title: Phantom 13.12 driver
Topic Summary:
Created On: 02/24/2014 05:42 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 02/24/2014 05:42 AM
User is offline View Users Profile Print this message

Author Icon
Manwe
Peon

Posts: 2
Joined: 02/24/2014

Main reason for posting is because I am getting BSODs once or twice per day in random situations. 

comp is:

intel i5 3570k

sapphire 290 TRI X (all default, no OC)

Thermaltake Thoughpower 750W

4x4GB Kinstone ram

Gigabyte Sniper m3 bios F10f (latest)

I bought the card end of January and installed 13.12. Few days later i installed 14.1 beta. Cant remember if I 1st deinstalled 13.12 or not. I am having BSODs last 3 weeks. Yesterday finaly installed win debug tools to check dump report. 

Error log says its the atikmpag.sys that is causing the trouble. 

First thing I tried was to deinstal 14.1 and go back to 13.12. Deinstall of beta driver goes ok but when its done a very interesting thing happens: screen reverts to some really low res (as expected without a driver) for a split second, than goes back to standard 1920*1200 I have on my Dell monitor. I went to device manager to check, and it says that a AMD driver from 6th of December is present and working!!! Somehow that driver from 13.12 pack is still there!?

After that, I ran the 13.12 deinstal and it says that there is nothing to deinstal. I tried to install same 13.12 instead. After 20 or so seconds I would get

---------------------------

InstallManagerApp

---------------------------

Application Install: install package failure!

---------------------------

OK   

---------------------------

Tried 5-6 times. 
In short, deinstall and install of 14.1 beta works ok. WHile using it, getting BSODs. When I deinstall it, I have 13.12 driver automatically somehow with no amd control panel, overdrive, nothing. How to unistall this?
Any ideas greatly appreciated!
 02/25/2014 04:13 AM
User is offline View Users Profile Print this message

Author Icon
Manwe
Peon

Posts: 2
Joined: 02/24/2014

Solved by booting in safe mode and using Display Driver Uninstaller (DDU) V12.3. It fully cleared all AMD software. Installed 13.12 after it with no problems. No BSODs so far (12 hours). 

Statistics
81003 users are registered to the AMD Support and Game forum.
There are currently 0 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.