Topic Title: Install Problems: Catalyst Control Center with 14.2 beta 1.3
Topic Summary:
Created On: 03/02/2014 04:26 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 03/02/2014 04:26 PM
User is offline View Users Profile Print this message

Author Icon
NoelCarboni
Peon

Posts: 27
Joined: 08/03/2011

Because I have had (very) occasional problems waking my two monitors from power-down screen save mode, I decided to try to install the latest Catalyst beta release.  I have a Windows 8.1 Pro x64 system with a Radeon 7850 that runs flawlessly save for the aforementioned problem.

I followed the instructions and uninstalled Catalyst 13.12 first, then tried to install the beta.

It stalled at "Installing Catalyst Control Center", where it appeared to be retrying, as the lower progress bar would go across part way, then hop back.

I went through this a number of times, even going so far as using the AMD cleanup utilty (and of course rebooting bunches of times).

I finally got the installation to complete by killing individual MSInstall.exe processes with Task Manager after they stalled (I had to do this a total of twice), after which the overall installer claimed to have finished.  Then I ran a "Repair" installation from the Programs and Features "AMD Catalyst Install Manager", which completed.

Now everything runs well.  I even, per benchmarks, picked up a few percent in Windows desktop speed.  Surprisingly, the speed of 3D operations remained about the same.

ATI really ought to try to make its installers more robust.

-Noel



-------------------------
Statistics
84320 users are registered to the AMD Support and Game forum.
There are currently 6 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.