Topic Title: Catalyst Control Centre Won't Open
Topic Summary: Trying to launch the application fails to open the program
Created On: 03/06/2014 04:26 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 03/06/2014 04:26 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 6
Joined: 02/02/2014

Hi All,

So I've got a problem trying to launch the Catalyst Control Centre.  I'm running Windows 8.1 Pro (64-bit) and have installed the latest Beta Drivers 14.2

When I try the launch the application I get the spinning circle to indicate that it is thinking about it, but then it simply does nothing.

So I initially tried uninstalling everything, rebooting, reinstalling the drivers and CCC, rebooting and then trying to launch the application.... No Good!

Then I tried just installing the CCC from the install folder and this also failed to fix the problem.

This issue isn't just related to the latest drivers or CCC.  As I unistalled all the drivers and CCC and reinstalled a lower driver package and CCC failed to run in that version also.

Just wondering if anyone else is having this problem and if they were able to fix it.  Very frustrating!


Intel i7-4770k,
ASRock Z87 Extreme9/ac,
8GB G.Skill DDR3 RAM,
2 x Gigabyte R9 290X GPUs,
1000W PSU,
1 x Corsair SSD,
1 x WD Caviar Black 2TB,
1 x WD Caviar Green 3TB,
All watercooled by XSPC

93374 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.