Topic Title: R9 290X Crossfire problem
Topic Summary: Bad performance with 2x R9 290X in crossfire..single GPU is better (help)
Created On: 03/09/2014 11:35 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 03/09/2014 11:35 PM
User is offline View Users Profile Print this message

Author Icon
Aberu
Peon

Posts: 2
Joined: 11/11/2009

Hello, 

Im a noob at forums, but ive been all over looking for an answer and i hope i can find it here...or at least be pointed in the right direction.

Here is my setup:

Windows 7 ultimate 64bit

ASRock Fatl1ty 990FX Professional MB

2X -  R9 290X @ PCIe 2.0 X 16 (each lane) (memory is hynix & elpida both are XFX cards purchased together)

16 Gig Corsair Vengeance @ 9-9-9-27 1T @ 1600Mhz @ 1.5v

Antec 1000W PSU

2Tb HD

FX-8350 @ 4.6 1.48v

Air cooled, Antec DF-85 tower with Corsair H80 for CPU cooling.

60inch LG Plasma 1080p

 

Ok, so what i experience is this, single GPU perfromance is great, but using both GPUS (crossfire) and all my performance goes out the window...Now, i have done "disableULPS" , also used GPU-Z render test that shows both cards at 16x each lane, and removed and reinstalled AMD drivers, 13.12 and the 14.2 beta..even using driver sweeper to make sure i start on a clean slate...but nothing seems to be making a difference, the last time i played Bioshock Infinite was horrible on crossfire, sound "pops" and bad freamerate, but on a single card...its perfect. What gives?? I been on google, up and down seeing other people that have the same problems...some actually get solved by the "ULPS" thing...but im still stuck, PLEASE, if anyonce can shed some info on where to proceed next...i will be greatful.

Thanks,

Aberu

Statistics
89046 users are registered to the AMD Support and Game forum.
There are currently 0 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.