Topic Title: Unable to install/update drivers on HD 6670
Topic Summary: I've tried everything!
Created On: 03/14/2014 05:50 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 03/14/2014 05:50 PM
User is offline View Users Profile Print this message

Author Icon
blabla894
Peon

Posts: 3
Joined: 01/23/2014

Graphics Card
-AMD Radeon HD 6670, not really sure what model.

AMD Catalyst Driver Version, and Driver History
-None now I guess, I've had 8 point something driver for about 2 years, before I uninstalled and tried to update.

Operating System
-Windows 7 Ultimate 32-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.130828-1532)

Issue Details

-Hello,

First of all, have in mind that this is a really old computer.

I've been using an old, 8.something driver for some time now. I remember having similar problems installing that one or two years ago. I think in the end I installed it in the device manager, looking up the driver file manually, and since then, it's been like that, unable to update. I've tried updating, with the install manager, and it ends with errors. I can't open the log for the details, when I click the View Log button, nothing happens. I'm trying with the newest driver version (13-12_win7_win8_32_dd_ccc_whql).

I've tried everything from the posts offered. Tried uninstalling the drivers regularly, which resulted in errors, leaving the driver intact. I did not find the Public Key Token file you mentioned. Then, I did a clean uninstall with Display Driver Uninstaller, in safe mode. I think it succeeded, it's behaving like there is no drivers, dxdiag is not finding anything. But, in the Device Manager, it shows AMD Radeon HD 6000 series, and when I open properties, there's a driver version 8.850.0.0. In driver details it lists files under C:\Windows\System32. Should I uninstall that? Anyway, I tried to install fresh drivers, but again, errors, and no changes to drivers happen. Only AMD Catalyst Install Manager is installed. Still, nothing happens when I press the View Log button.

What am I supposed to do?

Also, I've disabled the antivirus.


Motherboard or System Make & Model
-M2N-X Plus (0x00000316 - 0x15A14138)

Power Supply
-Not really sure, I can look it up if it matters.

Display Device(s) and Connection(s) Used

-SAMSUNG SyncMaster 943N

CPU Details
AMD Athlon(tm) 64 X2 Dual Core Processor 4000+ (2 CPUs), ~2.1GHz

Motherboard BIOS Version
-BIOS: BIOS Date: 10/23/07 10:33:42 Ver: 08.00.12
A copy from dxdiag, I'm guessing this is it?

System Memory Type & Amount

2x1GB

Memory type - DDR2

Module format Regular - UDIMM

Manufacturer (ID) - Transcend Information (7F4F000000000000)

Max bandwidth - PC2-5300 (333 MHz)

Part number - JM667QLJ-1G

Additional Hardware

SAMSUNG HD161HJ

Capacity 149.0 GB

Additional Details
-The computer is regularly checked, there are no viruses or hardware problems.

Statistics
85324 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.