Topic Title: AMD 14.2 Install failure, system rollback and following anomalies
Topic Summary: Experiencing strange occurences after a failed install
Created On: 03/30/2014 03:49 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 03/30/2014 03:49 PM
User is offline View Users Profile Print this message

Author Icon
SzikraTheDragon
Peon

Posts: 1
Joined: 03/30/2014

Hello everyone!

I've recently installed an SSD in my computer and soon after installing a 64bit Win 8 OS on it, I moved on to instally the VGA driver for my Sapphire HD 7870 2GB GHZ edition card.

Since I had no issues with beta drivers prior, I decided on the 14.2 beta driver using the wizard, installed everything as it suggested. (including something called an AHCI driver, which I guessed might be SSD related?)
After that, a mandatory system restart started, which ended up in an endless loop on the Windows logo...
I had to restart the system and since couldn't start otherwise, use the system restore to restore to an earlier state, after which I attempted installing the beta driver again, this time succeeding. That's where the problems started.

Here is what I have experienced:

-Unable to start games on full-screen, resulting in something like a constant alt-tabbing to desktop. Eventually I might have managed to start it in windowed mode, but even then, changin any in game setting ended up on desktop again.
-In settings the 60hz mode, I used previously disappeared, 59,94hz were the new max setting at 1920x1080 (I have found out this to be normal and related to me using a SAMSUNG P2270HD HDTV...)
-Occasionally, games ended up in a distorted full screen. The screen zoomed into a gigantic magnification, magnifying a part of the screen, with my mouse cursor being half-the screen sized. Condition persisted in Windows too, only restarting helped.

After all these, I have decided to remove the driver with the clean uninstall tool, even checked registry and manually for remaining folders and then after a restart installed the 13.12 drivers. After this, the alt-tab problem persisted, until I tried two settings:
Ticked the "Lower DVI fequency on high resolution screens" and the "Automatic GPU Scaling". This solved the auto-alt tabbing bug and finally I could start games and they worked without problems, with a few exceptions tough:

-59,94hz is still largest selectable refresh rate (Doesn't really matter tough)
-The Windows colour correction settings, reset each restart. Looks like Catalyst takes over the control of it every time.
-Occasionally still happens that a game starts in windowed mode, forgetting my full-screen settings.
-VERY RARELY the premanent alt-tabbing like error resurfaces. In these cases a system restart helps.


So this is my current state of being. I suppose something went wrong with the first beta driver install, that is still haunting the system ever since, despite the clean ups. Maybe someone knows here, what could be the cause. Any help is much appreciated!

My system:

SAMSUNG P2270HD HDTV monitor on a DVI connection.
SAPPHIRE HD7870 GHZ Edition 2Gb
ASUS M5A78L USB3 Motherboard
8GB Kingston DDR3 1600 MHz RAM
FSP Aurum Gold AS-600 - 600 Watt Power supply
Catalyst: 13.13 Version
Windows 8 x64

Games tried: Battlefield 4 / Wargame:Red Dragon -beta / Faster Than Light

 04/02/2014 05:29 PM
User is offline View Users Profile Print this message

Author Icon
ATInerb1
Peon

Posts: 11
Joined: 12/18/2013

Your AHCI driver is the SATA controller (hard drives).

 

For your Samsung P2270 HD TV it sounds like a unsupported driver issue (AMD doesn't have a profile for your TV I'm thinking) but a forum user named bacano7 posted previously on a possible fix.

 

Originally posted by: bacano7 Go to http://forums.guru3d.com/showthread.php?p=4736839#post4736839 follow those steps and the problem will be solved.

 

Original thread here.

[code]http://forums.amd.com/game/messageview.cfm?catid=454&threadid=172475&enterthread=y[/code]

 

If you need to do a clean driver install Stumped did a great post about it here.

Statistics
84238 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.