Topic Title: R9 290 not smooth with v sync ON 60 fps world of warcraft, beta drivers
Topic Summary:
Created On: 03/30/2014 04:48 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 03/30/2014 04:48 PM
User is offline View Users Profile Print this message

Author Icon
xixou
Peon

Posts: 10
Joined: 01/30/2008

R9 290 not smooth with v sync ON 60 fps world of warcraft, beta drivers

The problem is the frequency switching of the RAM/CORE of the R9 290,

with the betas drivers (AMD_Catalyst_14.3_Beta_V1.0_Windows_B22_March12.exe or AMD_Catalyst_142_Beta13-[Guru3D.com].exe),

RAM switches between 150 and 1300 MHz !

When I force the Frequency to a fixed value, with msi afterburner (even low), then the v sync issue is gone, the world of wracraft game is smooth like with the 13-12_win7_win8_64_dd_ccc_whql.exe drivers.

Looking at the watt meter on the AC plug, the consumption is quite close to the dynamic AMD switching implementation.

I would suggest to AMD to add an option in the overclock tab of the Catalyst

to enable the fixed memory/core frequencies.

Is there any chance they gona add that ?

By also switching the Ultra low power stuff, the pci express bus toggles between

2.0 16x lanes to 1.1 1x lane, which is non sense while playing a game(because of the low load).

I will add a video showing the problem Tomorrow.

 03/31/2014 05:45 PM
User is offline View Users Profile Print this message

Author Icon
xixou
Peon

Posts: 10
Joined: 01/30/2008

Well, the problem is not related with the clocks.
I found out that the problem is somewhere in the post processing, after the 3D rendering.
If you play world of warcraft in windows mode, you will get a lot of stutter.
If now you put on top of the world of warcraft windows another windows, like gpuz or msi afterburner (select the tool to be always in front), then the game is perfect smooth.
The same happens when playing videos using vlc media player,
if you show the statistics windows, there will be stutter when playing a video, that is actually loosing frames (randomly) !
The counter raises in the statistic when it is not smooth.
Would be great if AMD checks what is going on over there !

 03/31/2014 06:28 PM
User is offline View Users Profile Print this message

Author Icon
xixou
Peon

Posts: 10
Joined: 01/30/2008

Well, If I fix the frequency, vlc media player shows 0 frame lost.

So it is related to frequency after all.

 03/31/2014 08:39 PM
User is offline View Users Profile Print this message

Author Icon
7stars
Peon

Posts: 35
Joined: 04/18/2013

yes, seems there's an issue with PowerPlay (powertune) with beta drivers 14.x and they should know...

i already reported to betareport form

please all of you do the same and report this bug, so we can expect that in April they solve for fixed clocks in high performance mode....

http://www.amd.com/betareport

i don't want the GPU core to drop its frequency while playing games...seems reasonable with a 290

Originally posted by: xixouI would suggest to AMD to add an option in the overclock tab of the Catalyst

to enable the fixed memory/core frequencies.

 

 

yes, good idea...the same i suggested inside the betareport form...

an auto mode, managed by "powerplay" BUT even a TOTALLY MANUAL mode... where you can choose stock or overclock FIXED frequencies, and if needed by high temp...just increase the fan speed

OR use Sapphire TriXX BUT without PowerPlay support and no drops, also sent a ticket to Sapphire for the same reason....



Edited: 03/31/2014 at 08:54 PM by 7stars
 03/31/2014 11:51 PM
User is offline View Users Profile Print this message

Author Icon
UcouldBrong
Overclocker

Posts: 797
Joined: 01/05/2013

Well, these were certainly two amazing analyses that leave me speechless in my ignorance!  Do carry on.  Want to see how this all ends!



-------------------------

 


 


Non-noob components.

 04/01/2014 12:52 AM
User is offline View Users Profile Print this message

Author Icon
xixou
Peon

Posts: 10
Joined: 01/30/2008

Originally posted by: UcouldBrong Well, these were certainly two amazing analyses that leave me speechless in my ignorance!  Do carry on.  Want to see how this all ends!

 

Thanks ;-)

 

Is there a tools to edit the bios to force a fix frequency ? If that can fix the problem ;-)

In the past I was using the ati bios editor with success.

I have a shaphire tri X so there is definitely no heat issue.

 

 04/01/2014 04:53 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4878
Joined: 12/27/2008

Originally posted by: xixou

Thanks ;-)

Is there a tools to edit the bios to force a fix frequency ? If that can fix the problem ;-)

In the past I was using the ati bios editor with success.

I have a shaphire tri X so there is definitely no heat issue.

Yes, there is, but it doesn't support the R series yet. It's called RBE (Radeon Bios Editor), you can keep an eye on it for later support.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 04/01/2014 06:34 PM
User is offline View Users Profile Print this message

Author Icon
xixou
Peon

Posts: 10
Joined: 01/30/2008

Hi,

After testing all night (I tweaked the registry settings for the power threshold and so on), I finally found the problem.

The conclusion is very simple ;-)

For some reason world of warcraft sync at 50 fps instead of 60 fps,

but still shows a frame rate in the stats (or with fraps) at 60 fps.

This gives the very choppy situation.

I could see it because after doing an exit of wow, the config.wtf was updated with those lines:

 

SET gxVSync "1"

SET gxRefresh "50/1"

When you restart the game, the line SET gxRefresh "50/1"

is then automatically removed (funny, they add them themselfs but then remove it).

I took a picture where it was for some reason indicating that the frame rate setting was not matching the preferences (and so the light came in my llittle brain after all ;-).

So the easiest solution to solve it is to select 50 Hz in the settings (when in full screen mode), apply it, then 60 Hz and apply.

Blazing smooth game now, with beta file name AMD_Catalyst_14.3_Beta_V1.0_Windows_B22_March12.exe

If you play in windows mode, play with the catalyst screen refresh rate of bit depth, that also works making wow aligned with the GPU.

I hope that will solve at your side the stuttering.

Let me know if that is the case ;-)

 

Statistics
84900 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.