Topic Title: OpenCL support is wiped out on every reboot
Topic Summary:
Created On: 04/01/2014 12:11 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 04/01/2014 12:11 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 1
Joined: 03/20/2014

I have this weird problem with OpenCL support. It's been present forever (as far as I remember), but it wasn't important to me until I added an OpenCL project for BOINC.

I have Radeon HD 5850 (XFX brand) and Windows 7 Ultimate x64. The OpenCL support does not survive a reboot. After a reboot BOINC manager reports that GPU is missing. When I run GPU-Z it also does not show OpenCL as present, in fact DirectCompute 5.0 is not present either. My current driver is 13.12, but like I said this was a problem with all the previous versions. I did uninstall the driver, even ran the AMD cleanup utility and also Driver Sweeper, did a clean install (a couple of months ago), but the problem still persists. I can run the setup again (which runs only 2 minutes when run not the first time for the particular driver version, otherwise it's much longer) and it seems to repair what's wrong, because the OpenCL and DirectCompute support come back. Until the computer is rebooted...

I tested many times for any missing driver files after a reboot and before running driver setup again and all driver files (that I could identify, but I'm pretty much sure about this) are there, no file is missing or back leveled by something that runs during the boot up process. I'm pretty convinced that it is the registry entries that are being damaged. Everything else seems to be fine, it's only OpenCL and DirectCompute support that is damaged after a reboot. Recently while troubleshooting a Windows Update problem I discovered a key in the registry that was inaccessible/unreadable. Nothing (absolutely nothing!!!) could be done to that key. I could not open it, change permissions, delete... nothing but rename the parent key and recreate the whole tree. No tool that I found online while researching the problem could help. I could not do anything even when I booted to a different partition and opened the registy hive while it was not used.

Anyway, I'm suspecting something similar with a registry key (or keys) for OpenCL support. Some key is not properly saved, because it's damaged, but it is maintained in some kind of a dynamic configuration that doesn't get saved. I'm not a Windows guru by any means, it's just my wild guess. I could be wrong though, but what else could it be? Why the OpenCL support is wiped every time the system is rebooted?

So, could somebody give me a list of registry keys for OpenCL support (and DirectCompute too), so I could verify that in the registry of the affected machine? Or maybe somebody has experienced the same issue before and knows what it may be? I'm open to any suggestion (except those that I've already tried, like driver clean install, etc.) and thanks in advance for any help.



93355 users are registered to the AMD Support and Game forum.
There are currently 5 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.