Topic Title: XFX R9 280x not HDCP compatible?!
Topic Summary:
Created On: 04/10/2014 01:03 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 04/10/2014 01:03 AM
User is offline View Users Profile Print this message

Author Icon
Fiyero
Peon

Posts: 3
Joined: 04/10/2014

So I just purchased a XFX R9 280x graphics card and now my computer is no longer HDCP.

When I unistall catalyst and take the card out my onboard intel graphics works just fine with blu rays and the BD Advisor checks out just fine.

When I do a fresh install on my Windows 8.1 machine with the XFX it once again goes back to saying :

Connector Type" HDMI(Not HDCP Compliant)

Ive tried different cables and thats not the issue I also disabled Hyper V still nothing. My monitor is a 3D monitor so its also HDCP compliant. Im stumped with this especially since its abrand new system and card.

 

Any Ideas? XFX and AMD are absolutely no help I alreadyw ent through them and they gave me a run around about uninstalling and reinstalling which ive done twice to no avail .

 04/16/2014 02:27 PM
User is offline View Users Profile Print this message

Author Icon
Dr_Tyack
Peon

Posts: 4
Joined: 04/09/2014

Hi,

I am having the exact same issue also with the XFX DD Black edition.

Have you had any luck on this?

I am running intel 4670k with hd4600 graphics fine as you are. I have contacted the card supplier (scan) and they have advised that all AMD cards are (or should be) HDCP compliant

I am able to play bluerays through the card but only on a DVI monitor via DVI cable.

I have already tried several things such as purchasing a high speed HDMI cable (which are needed for 3D anyway to my understanding), disabling all other monitors and using a different TV all to no avail.

Let me know if you find / have found a resolution

 

 04/19/2014 11:41 PM
User is offline View Users Profile Print this message

Author Icon
Fiyero
Peon

Posts: 3
Joined: 04/10/2014

Yes I Have the DD version as well and nope not a single fix available im on week two of trying things and nothing works! The card is simply not HDCP compliant they must have messed up on the software side of things like the BIOS or something. It's funny the actually card itself registers as HDCP compliant but the HDMI port is not go figure. Also AMD and XFX will not help you so dont bother ive already tried. 

I think they should be ashamed of releasing something that doesnt work for so much money but I dunno.

 05/13/2014 05:47 AM
User is offline View Users Profile Print this message

Author Icon
Barbara917
Peon

Posts: 1
Joined: 05/13/2014

I have the XFX DD R9 280x card and it appears that I have the same problem.

I am running Windows 7 64-bit Professional

I have a Silverstone Slim Slot Loading Bluray Optical Drive and am using the Cyberlink PowerDVD 12 software. At first I suspected the software. I uninstalled it. Updated the AMD Catalyst Driver to version 14.4. I then re-installed  the Cyberlink software with anti-virus turned off. No dice.

I know that the Cyberlink software works and my HDTV are both HDCP compliant because I have installed the software on a separate system using an older XFX HD 5850 graphics card. That card and the same PowerDVd software work fine to play bluray disks just fine and I do not get the HDCP compliant error.

I haven't yet tried AMD or XFX support because I wasn't sure it was the graphics card until I read this thread and saw others with the same problem. I am still not sure if this is and AMD driver problem or if this is inherent to the XFX manufactured R9 280x cards.

 05/13/2014 06:26 AM
User is offline View Users Profile Print this message

Author Icon
Dr_Tyack
Peon

Posts: 4
Joined: 04/09/2014

I have now RMA'd my card. Currently with the supplier for testing. They have taken 2 weeks so far and no updates.its a real shame but had to be done as both xfx and AMD have not responded to me. its a really nice card otherwise.will update when i get anymore info back.
 05/17/2014 05:40 AM
User is offline View Users Profile Print this message

Author Icon
Dr_Tyack
Peon

Posts: 4
Joined: 04/09/2014

Hi guys, quick update. Scan tested the card and confirmed the fault, also they tested another of the same card and guess what- same fault. i have now gone Nvidia 770.  - managed to get a free game out of scan as a constellation prize! great customer service on their part.

 05/20/2014 07:58 AM
User is offline View Users Profile Print this message

Author Icon
M4rk
Peon

Posts: 7
Joined: 04/22/2014

did u check this topic? Do you have my same problems?

 

http://forums.amd.com/game/messageview.cfm?catid=454&threadid=173177&enterthread=y

 

thx

 05/20/2014 01:31 PM
User is offline View Users Profile Print this message

Author Icon
M4rk
Peon

Posts: 7
Joined: 04/22/2014

Fiyero you are a genius!

My hdmi problem are hdcp related, the vga cut audio when using the hdmi output, i used the Cyberlink BD Advisor and i found your same problem "Not hdcp compilant", what now? whait for a fix or make rma?

 06/21/2014 09:49 PM
User is offline View Users Profile Print this message

Author Icon
Spazzy2004
Peon

Posts: 7
Joined: 06/21/2014

I'm having the same problem with my XFX R9 280x. I can't play blu-ray with this card.

I singled out that the problem is the card because it works using the same cable and same tv but with the integrated GPU.

I tried the 14.4 WHWL drivers and 14.6 beta and it still didn't work.

I've also tried with Corel DVD pro and Power dvd and I'm getting the same HDCP non compliance error message.

 

It's too bad because this card is a beast.

 

Did getting a new RMA card fix the issue or anyone found a way around it other than anydvd?

 

 

 

 06/22/2014 09:27 AM
User is offline View Users Profile Print this message

Author Icon
backFireX64
Elite

Posts: 1038
Joined: 11/14/2010

Have you tried connecting the cable on different display ports on the back of the card ?



-------------------------

gigabyte X58A-UD3R rev.2, core i7 975 3.9ghz (stock voltage), windows 8.1 64-bit, corsair 12gb DDR3 1600mhz 7-7-7-20 RAM, sapphire HD 6990 (stock clocks), coolermaster ultimate 900w PSU.
amd catalyst 14.6 RC2 june23

 06/22/2014 02:15 PM
User is offline View Users Profile Print this message

Author Icon
Spazzy2004
Peon

Posts: 7
Joined: 06/21/2014

Like Dr Tyak mentionned, it works through dvi but does not work with HDMI.

 

I'm hoping that it's a driver issue and could possibly be fixed with the next catalyst release.

 

 06/22/2014 03:49 PM
User is offline View Users Profile Print this message

Author Icon
backFireX64
Elite

Posts: 1038
Joined: 11/14/2010

No, i mean a port other than the ones tested.



-------------------------

gigabyte X58A-UD3R rev.2, core i7 975 3.9ghz (stock voltage), windows 8.1 64-bit, corsair 12gb DDR3 1600mhz 7-7-7-20 RAM, sapphire HD 6990 (stock clocks), coolermaster ultimate 900w PSU.
amd catalyst 14.6 RC2 june23

 06/22/2014 09:36 PM
User is offline View Users Profile Print this message

Author Icon
Spazzy2004
Peon

Posts: 7
Joined: 06/21/2014

I just tried the mini display ports and the DVI and it works. It really seems to be isolated with the HDMI that seem to have a handshake issue with the HDCP from the card through the HDMI and to the TV.

Is this with all XFX R9 280x?

 

 06/22/2014 09:56 PM
User is offline View Users Profile Print this message

Author Icon
backFireX64
Elite

Posts: 1038
Joined: 11/14/2010

Glad you sorted it out.

 

HDMI port should not give this issue on this card.

Unacceptable, and make sure to send a complaint to amd

 

 



-------------------------

gigabyte X58A-UD3R rev.2, core i7 975 3.9ghz (stock voltage), windows 8.1 64-bit, corsair 12gb DDR3 1600mhz 7-7-7-20 RAM, sapphire HD 6990 (stock clocks), coolermaster ultimate 900w PSU.
amd catalyst 14.6 RC2 june23

 06/23/2014 01:21 AM
User is offline View Users Profile Print this message

Author Icon
Spazzy2004
Peon

Posts: 7
Joined: 06/21/2014

Can anyone confirm that you can play blu-rays through HDMI with the XFX R9 280x ?

 06/25/2014 02:42 PM
User is offline View Users Profile Print this message

Author Icon
Spazzy2004
Peon

Posts: 7
Joined: 06/21/2014

Update: XFX confirmed that the HDMI port on the XFX r9 280x DD is not HDCP compliant.

All the other ports, mini display ports and DVI are HDCP compliant but not he HDMI.

They offered a free Mini DisplayPort to HDMI adapter or an RMA, I wonder what they will RMA it with if it affects all cards.

 

I'm still unsure what option to take.

Statistics
84189 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.