Topic Title: AMD Catalyst 14.7 RC - AMD Catalyst Control Center missworks
Topic Summary: AMD CCC does not display all the options, i.e. no 'Video' and 'Gaming' options
Created On: 07/22/2014 04:28 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 07/22/2014 04:28 AM
User is offline View Users Profile Print this message

Author Icon
grnt
Peon

Posts: 4
Joined: 07/20/2014

OS: Windows Server 2012 R2 x64

Video: Sapphire AMD R9 290

Driver version: AMD Catalyst 13.12, 14.4 and 14.7 RC

Dear forumers and developers!

I already met with the failure of AMD CCC (Vision Engine Control Center) of AMD Catalyst 12.6 under Windows 7 x64 - when it displayed not all the options, i.e. no 'Gaming' and 'Video' options! The way to solve it is described here:

http://www.tomshardware.co.uk/forum/1171-73-majority-options-catalyst-control-centre-upgrading

Now the bug reveals under Windows Server 2012 R2, it is possible under new Windows 8.1, I suppose. More over, CCC 'dislikes' the presence of other drivers (and maybe physical presence of cards) in the device manager, under Windows Server 2012 R2 it 'dislikes' Microsoft Video Driver (if I translate it correctly).

I want to pay attention of the developers who may easily make CCC workable under new Windows Server 2012 R2, but probably do not want to and do not read my messages to the end!

Here is my previous message where I wrote about 1 CPU core loading at 100%:

http://forums.amd.com/game/categories.cfm?catid=454&flcache=6424433&entercat=y

The CPU core loading at 100% successfully stopped, I'm sure it was connected with .NET assemblies regeneration - but now we deal with a new 'old' bug! How long will it last?

Thank you, in advance.

Grant L. Atoyan

 

 07/23/2014 04:59 PM
User is offline View Users Profile Print this message

Author Icon
grnt
Peon

Posts: 4
Joined: 07/20/2014

Sorry, I have to reply myself again.

Here is the solution - at last I've found out what's up. Again - those things are related to Server OSes.

I mean the bug is solved the same way it was solved for Catalyst 12.6 (and later) under Windows Server 2008 R2 - one-to-one! The page with that solution is not accessible now, only can be found in Google cache:

Edit 01/28/2012: As pointed out by JR in comments below (many thanks), there is a registry trick to work around the CCC warning of “The Catalyst Control Center is not supported by the driver version of your enabled graphics adapter”. For every GUID under HKLM\SYSTEM\ControlSet001\Control\Video\{GUID}000, check DeviceDescription. Skip entries like “Standard VGA Graphics Adapter”, “RDP Reflector Display Driver” and so on, and locate “ATI Mobility Radeon HD 4200 Series”. Then change Acceleration.Level from 4 to 0. After reboot, CCC runs without warning and allows me to adjust much more! In my case, I used Desktops and Displays | My VGA Displays | Image Adjustment, and I easily dragged the box in Screen Position and Size to move all the pixels into my HDTV’s displayable area.

So, everything remains the same for CCC 13.12 - 14.7 and Windows Server 2012 R2 - we have to change in the registry Acceleration.Level from 4 to 0. And the lost CCC options will come back! Who can tell me, why?

 

Statistics
88947 users are registered to the AMD Support and Game forum.
There are currently 0 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.