Topic Title: WOW display driver crashing
Topic Summary:
Created On: 12/02/2011 04:10 PM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 12/02/2011 04:10 PM
User is offline View Users Profile Print this message

Author Icon
SavageMG
n00b

Posts: 1
Joined: 12/02/2011

every time i try to make wow  windowed my display drivers crash   doing normal things  like entering instances heathing  runing around org   cause my display drivers to crash i didnt have this problem  untill  the  11/15  driver update   i have a  raedon 6770  any idias why this is happing  ( this also happens in skyrim)

 12/09/2011 02:16 PM
User is offline View Users Profile Print this message

Author Icon
stunkerson
n00b

Posts: 1
Joined: 12/09/2011

I'm sorry i have no help, but can second the experience.  Just-purchased HD-6850, cleaned previous drivers out well, I installed Catalyst 11.11 with appropriate driver and running WoW led to a black screen and reboot within moments of login.  Uninstalled thoroughly, installed just the 11.11 display driver from AMD/ATI, I still get random BSOD's and display drivers ceasing to work. 

Letting Win7 automatically install its driver of choice seemed to put a halt to the BSOD's and reboots, but there are still oddities and driver crashes going from FS to windowed mode, windowed FS mode pops up and obscures the desktop when alt-tabbing between other things.  Plus I'd like to be able to monitor temps with CCC, but installing that seems to be a one-way ticket to crashville.

Your experience tells me maybe I should try an older driver, this being my first ATI card in years I've got no experience of it working properly (and CCC appears to be the same exact buggy garbage it was years ago).

update:  11.10 was the previous version for you I believe but that was just as broken for me, in fact upon launching WoW the fan spun up to 100% before the system crashed.  

I seem to have found "stability" in WoW and elsewhere (as long as I don't go fullscreen) with the original CCC & driver that came on the CD with my Gigabyte HD-6850.  It appears to be version 10.9 and this old version of CCC is infinitely less irritating than the modern Vision software.

Beginning to doubt that upgrading drivers with ATI is worth it when nothing's broken, at least in my case.  So much for conventional wisdom.



-------------------------
CPU/MB: Phenom II x4 @ 3.3GHz (x2 550 black unlocked w/mild oc) on an Asus M4A785TD-V EVO, RAM: 8GB CAS 7 DDR3, Gfx: Gigabyte Ultra Durable GV-R685OC-1GD HD 6850, cooling: Noctua NH-C12P SE14 (cpu) in an Antec Illusion 300, PSU: Antec HCG-620 620W, OS Win 7 64-bit

Edited: 12/10/2011 at 03:46 PM by stunkerson
 12/24/2011 12:09 AM
User is offline View Users Profile Print this message

Author Icon
taheen74
Peon

Posts: 3
Joined: 12/24/2011

Wish I had gotten a screenie. Went to go do FL tonight and things just looked...well not right. Patches of the ground were colored wrong where they should be colored wrong (you don't even want to know what the Aly fight ground looked like). When we did have a wipe, even the death stuff looked wrong.  I have an HD 4650 and ever since this patch, I've been getting this oddball white screen right after I either hit play on the launcher or even try to boot from the wow.exe file. So, here I go and update my drivers.

All of the sudden, WoW doesn't want to play nice with Directx9 (I run Vista still). Something about shaders.  It runs with Directx 11 but the FPS is horrid doing that.

I think I'm just going to have to go back to the older version of the drivers.

 12/24/2011 04:07 AM
User is offline View Users Profile Print this message

Author Icon
BlackBandit
n00b

Posts: 1
Joined: 12/24/2011

YEP same problem here!!! mines an old one tho i needed to change my graphics card came in for wife so i took hers... I dont pvp she does so well i had your problem cant download on my computer WHY WHY WHY booted from guild and cant come back for missing FL Please could i talk to a live operater or something i cant seem to find how to do that!!!

Statistics
85470 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.