Topic Title: 6870 in serious trouble after catalyst 12.1
Topic Summary: 6870 Blackscreens fail to boot etc. with catalyst 12.1
Created On: 02/16/2012 05:58 PM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 02/16/2012 05:58 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 1
Joined: 02/16/2012

having had problems with ATI's drivers I ran my cards on the 11.11 drivers. (I tried a few others but these where the most stable on my system)
Yesterday The autoupdate asked me if I wanted to upgrade my drivers. I clicked NO. After a reboot My screen flashed once and then I got a no signal/cable conected. Now the screen is ruined I've tried it on my GF's comp but it just flashes on an off and then show a no signal message. Iv'e tried conecting my GF screen to my computer and it works for a few minutes but I only get image for a few seconds at a time. I managed to uninstall the graphics drivers and could work reasonably well for a while. I managed to DL the 11.11 drivers but Now the cards wont accept them or any other (11.3, 11.12, 11.10) drivers. I lose image imediatly on boot up.

I've tried installing other drivers, I took out one of the cards as I know Crossfire can cause problems, I cant even get in the bios so my hands are tied.
Any suggestions on what to try next?

I'm running
Win7 HomePremium sp1 64 on a
Formula III Rampage
I7 960 CPU
16Gb Corsair Vengence 1600
Dual Radeon 6870 Crossfire
Corsair TX 850W gpu.

 02/16/2012 07:40 PM
User is offline View Users Profile Print this message

Author Icon
Heavy Wizardry

Posts: 8828
Joined: 11/13/2009

I am assuming you mean the Catalyst suite asked if you wanted to update the drivers...not Microsoft update? If so, I always disable that in the options. Try downloading the newest drivers from AMD. Save them then express uninstall your old drivers from "remove a program" in the computer control panel. After driver sweeper  select AMD graphics drivers and delete all it finds. Reboot and install the new drivers.

I would also visit this page


Intel I7 960 @ 3.87ghz *Intel DX58SO *AMD R9 290 4gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit 

***** cetera fallunt, ludere mortuus ******

Edited: 02/16/2012 at 08:17 PM by stumped
93411 users are registered to the AMD Support and Game forum.
There are currently 7 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.