Topic Title: [Win7] problem with radeon HD5670 drivers
Topic Summary:
Created On: 03/18/2012 03:37 PM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 03/18/2012 03:37 PM
User is offline View Users Profile Print this message

Author Icon
darchrow
n00b

Posts: 6
Joined: 03/18/2012

Hi,
I have graphic card ATI Radeon HD5670, mainboard Gigabyte M62PME-S2 and operating system Windows 7 32 bit. I wanted to install new drivers to my graphic card and I downloaded it from producer website, but after installation i get message that any graphic driver is correctly installed. Altough if I install old drivers which I get with my graphic card its work without any problems. I,ve been told that i have to actualize my mainboard drivers earlier, but there is no drivers for my model and Windows 7, so I decided to download one for Windows Vista. But during instalation I get message "Installing program NVIDIA can not find drivers compatible with current hardware. Installing proggram will end work". What could be the reason of this problem? Is it system blame? What should I do?
Will be gratefull for help
 03/18/2012 04:10 PM
User is offline View Users Profile Print this message

Author Icon
Gr33nGecko
Long Time Member

Posts: 10027
Joined: 10/01/2009

 

Someone didn't read this :

GAME.AMD.COM Posting Guidelines: READ BEFORE POSTING



-------------------------
AM3 965BE C3 / 4GB Corsair XMS3 2000Mhz / GigaByte 990FXA-UD5 / Corsair H70 & 2 CM Excaliburs / x2 HD3870 ATOMIC Edition / Corsair 90GB Force 3 SSD / Momentus XT 250Gb Hybrid HDD / x3 Samsung F3 1Tb / Sony AD-7700 DVD-RW / Auzen X-Mystique / Enermax INFINITI 650W / Lian Li PC-7FNWB / Logitech X-530 / Logitech Kboard & MX620 Laser Mouse / Epson RX685 / DELL U2312HM 23" IPS TFT / MY RIG HERE
 03/18/2012 05:10 PM
User is offline View Users Profile Print this message

Author Icon
darchrow
n00b

Posts: 6
Joined: 03/18/2012

Motherboard:
CPU: AMD Athlon(tm) 62 X2 Dual Core Processor 6000+
RAM: 2x Goodram GW9E03397 2048 MB 128 bit
Video Card ATI Radeon HD5670:
PSU: Logic-400ATX, 400 watt
Hard drives: Seagate [I do not remember model and will not check on disk cover]
Optical Drives: [I do not remember model and will not check on disk cover]

Operating System: Microsoft Windows 7 32bit
Video Card Drivers in Use: ATI Technologies Inc. 2009-11-10, version: 8.673.0.0
Motherboard Drivers Used: Chipset driver: 15.00G, Realtek HD audio driver: 6.0.1.5449, Realtek LAN driver .101.1124.2006
 03/18/2012 06:11 PM
User is offline View Users Profile Print this message

Author Icon
Gr33nGecko
Long Time Member

Posts: 10027
Joined: 10/01/2009

 

Erm, there are dirvers for that mainboard and VGA card for Windows7 .. don't you look at things before doing anything ?

Mainboard chipset drivers for the AMD chipset board can be found on the AMD website ..

The Windows7 VGA drivers for the AMD VGA card you have can also be found on AMD's website ..

There's NOTHING in your system components from what I can see, which would require anything "nVidia" to be installed, so why are you installing nVidia drivers onto a platform made up from uniquely AMD parts ? ..

... system not to blame, USER error is to blame ..



-------------------------
AM3 965BE C3 / 4GB Corsair XMS3 2000Mhz / GigaByte 990FXA-UD5 / Corsair H70 & 2 CM Excaliburs / x2 HD3870 ATOMIC Edition / Corsair 90GB Force 3 SSD / Momentus XT 250Gb Hybrid HDD / x3 Samsung F3 1Tb / Sony AD-7700 DVD-RW / Auzen X-Mystique / Enermax INFINITI 650W / Lian Li PC-7FNWB / Logitech X-530 / Logitech Kboard & MX620 Laser Mouse / Epson RX685 / DELL U2312HM 23" IPS TFT / MY RIG HERE
 03/19/2012 03:22 AM
User is offline View Users Profile Print this message

Author Icon
darchrow
n00b

Posts: 6
Joined: 03/18/2012

I was lookong for drivers on this page: http://www.gigabyte.pl/products/page/mb/ga-m61pme-s2_2x/download/ . As you see there is no drivers for Windows 7, and I downloaded Windows Vista drivers. VGA driver from this page return error which I wrote earlier. There is integrated Nvidia graphic card on my mainboard.

Its still problem why drivers for my Radeon graphic card doesn't work
 03/19/2012 07:22 AM
User is offline View Users Profile Print this message

Author Icon
Gr33nGecko
Long Time Member

Posts: 10027
Joined: 10/01/2009

 

Ah right, got sent to a different board's page via google ..

OK, so you have an nVidia VGA card on the board, you don't have to install the drivers for that unless they're all-in-one drivers and you can't do anything about them being installed .. but you do need the chipset drivers to be installed correctly.

What you also need to do is to read your board's user manual and set the first boot display option to the discrete VGA card and not the onboard VGA card .. maybe that's why you're having so much trouble, that plus you're using Vista drivers on a W7 install, that too may be the root of your issues ..

Here, maybe actually try the correct drivers :

http://download.gigabyte.eu/FileList/Driver/motherboard_driver_chipset_nvidia_mcp68_win7-32.exe

ftp://download.gigabyte.ru/driver/motherboard_driver_chipset_nvidia_mcp68_win7-32.exe

http://download.gigabyte.ru/driver/motherboard_driver_chipset_nvidia_mcp68_win7-32.exe

 

 



-------------------------
AM3 965BE C3 / 4GB Corsair XMS3 2000Mhz / GigaByte 990FXA-UD5 / Corsair H70 & 2 CM Excaliburs / x2 HD3870 ATOMIC Edition / Corsair 90GB Force 3 SSD / Momentus XT 250Gb Hybrid HDD / x3 Samsung F3 1Tb / Sony AD-7700 DVD-RW / Auzen X-Mystique / Enermax INFINITI 650W / Lian Li PC-7FNWB / Logitech X-530 / Logitech Kboard & MX620 Laser Mouse / Epson RX685 / DELL U2312HM 23" IPS TFT / MY RIG HERE
 03/21/2012 01:37 PM
User is offline View Users Profile Print this message

Author Icon
darchrow
n00b

Posts: 6
Joined: 03/18/2012

it still doesn't work...

that's what I did: downloaded mainboard driver from your link, installed, rebooted, download new graphic driver, installed, rebooted, and it still doesn't work.

when I open "AMD VISION Engine Control Center" I get message: "There is no AMD graphic driver installed or AMD driver doesn't work properly. Install
right driver for your AMD hardware"
 03/22/2012 01:30 PM
User is offline View Users Profile Print this message

Author Icon
Gr33nGecko
Long Time Member

Posts: 10027
Joined: 10/01/2009

 

Well, either (i) you haven't set the mainboard BIOS up correctly (ii) you've got a Windows problem (iii) a combo of both ..



-------------------------
AM3 965BE C3 / 4GB Corsair XMS3 2000Mhz / GigaByte 990FXA-UD5 / Corsair H70 & 2 CM Excaliburs / x2 HD3870 ATOMIC Edition / Corsair 90GB Force 3 SSD / Momentus XT 250Gb Hybrid HDD / x3 Samsung F3 1Tb / Sony AD-7700 DVD-RW / Auzen X-Mystique / Enermax INFINITI 650W / Lian Li PC-7FNWB / Logitech X-530 / Logitech Kboard & MX620 Laser Mouse / Epson RX685 / DELL U2312HM 23" IPS TFT / MY RIG HERE
Statistics
84110 users are registered to the AMD Support and Game forum.
There are currently 7 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.