Topic Title: Medieval: Total War 1 not working on Windows 8 Consumer preview
Topic Summary:
Created On: 06/24/2012 03:20 PM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 06/24/2012 03:20 PM
User is offline View Users Profile Print this message

Author Icon
Maedroth
n00b

Posts: 3
Joined: 06/24/2012

I installed Medieval: Total War 1 on my machine after "up"-grading to Windows 8 Consumer Preview and it crashes before it got to  the main menu screen.Any help/advice would be most welcome.

-------------------------
 06/24/2012 03:33 PM
User is offline View Users Profile Print this message

Author Icon
sloots
Member

Posts: 144
Joined: 04/16/2010

 

What, surprised that a decade old game is having issues running under a beta operating system with beta VGA drivers ?? ?? ?? You'll have to fill out the driver feedback form ..

 06/24/2012 04:42 PM
User is offline View Users Profile Print this message

Author Icon
Maedroth
n00b

Posts: 3
Joined: 06/24/2012

Where would I find this form?

-------------------------
 06/24/2012 05:14 PM
User is offline View Users Profile Print this message

Author Icon
sloots
Member

Posts: 144
Joined: 04/16/2010

 

On the AMD website.

 06/25/2012 04:03 AM
User is offline View Users Profile Print this message

Author Icon
Maedroth
n00b

Posts: 3
Joined: 06/24/2012

Thanks.

-------------------------
Statistics
84673 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.