Topic Title: Upgrade to eyefinity 7970 failure
Topic Summary: Eyefinity worked on 5850 but doesnt work on upgrade to a 7970
Created On: 07/24/2013 01:42 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 07/24/2013 01:42 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 2
Joined: 07/24/2013

Hello to you all.

I have been running a HD5850 for a good six months with three identical Asus VN247 monitors in eyefinity. The three displays are connected with on on HDMI, one on DVI and the other via Displayport to DVI using a Wicked wired ACTIVE adapter. This configuration has been rock solid with no major issues, I even get HDMI pass through sound to my AV receiver.

I decided the other day to upgrade to a HD7970 thinking that it would be simple swap out, only to find that this new card doesn't appear to want to play with the wicked wirer adapter. The monitor connected via the adapter is detected but is either detected as 'Unknown' or 'Fake', unplugging the adapter whilst the PC is on can sometimes fix this issue and get the monitor correctly identified however I cannot get the monitor to sit on 1080P at 60hz with any consistency. I either get an error that the ATI driver has malfunctioned or the desktop flickers and stabilises at 640x480 @ 60hz. Trying to force 1080p immediately removes the option of 60hz and the desktop will only try but fail to lock into 1080p with a strange shuddering at 30hz. I also notice that I am unable to adjust scaling options on this monitor and its HDTV profiles are all missing.

I have tried everthing I can think of to get this new card working, old 11.6 drivers, bleeding edge beta drivers, driver cleaning, starting with just the DP monitor, then adding the other two monitors later all but to no avail.

I note that starting with only the DP monitor plugged I have on a few occasions been able to get logged into the desktop at 1080P @60hz but as soon as I add the other two monitors, the DP connection drops to 800x600 and if I have managed to get an eyefinity group setup (which I have!) I can only a single screen thats 2400x600, any option to up the resolution is simply not displayed.

As I type this, I have had to remove the new card and revert back to the 5850 and am once again stable @5760x1080 in eyefinity thus proving that the adapter is not at fault.

I realise that this adapter is not on the AMD approved list, however in Australia its hard to find anything else unless you order internationally and I assume that the enthusiast PC stores in Australia would not only sell this adapter if it simply didn't work.  I also assumed that I can't be the only person trying to run this wicked wired adapter with a HD7970.

Anyone out there with advice, or seeing the same issue please?






 07/25/2013 03:31 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 2
Joined: 07/24/2013

Just thought I would reply to my own post just in case others may benefit. I sourced and purchased an alternative ACTIVE DP to DVI adapter one of which was on the AMD list of certified dongles and the 7970 works perfectly with all issues resolved.

I chose the Accell B087B-005B which is an ACTIVE single link DVI-D. I did not go for a dual link as my monitors are all only 1080P.

Just as a closing comment, there seems to be a lot of fud on the interweb about ACTIVE meaning you need a USB feed for power, this is definately not the case.


93071 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.