Topic Title: HELP cannot get Radeon HD5700 series working with three monitors
Topic Summary: Have the active DisplayPort adapter but still no mojo
Created On: 08/17/2013 07:58 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/17/2013 07:58 AM
User is offline View Users Profile Print this message

Author Icon
krhen
Peon

Posts: 3
Joined: 08/14/2013

I have an ATI Radeon HD5700 series (per Windows 8 device manager) - unsure of specific model, but it has two slots covered and the first has DVI HDMI and DisplayPort connectors.  Second has only DVI.

 

Latest drivers are installed.  Win8 64 bit.

 

First two monitors are connected via the DVI ports.

 

Third is connected through an Accell DisplayPort to DVI-D Active Single-Link Adapter SKU  B087B-005B  which is approved.

 

The two displays on DVI work fine of course.

 

Connect the third through the DisplayPort AdapterStart Catalyst Control CenterUnder COMMON DISPLAY TASKS -> Detect Displays, I see three displays, one disabled.

 

I then go to the AMD EYEFINITY MULTI-DISPLAY -> Create EyeFinity Display Grouponly shows me two dispays.

 

I go back and disable the second display.  Now only on one.

 

Then back to AMD EYEFINITY MULTI-DISPLAY -> Create EyeFinity Display GroupI select the one display and create a group - seems ok.   Selected "3 Displays (3 x 1)" from the dropdown.  Hit continue.  Catalyst Control Center says "Completed: Creation of an AMD Eyefinity Display group with 3 displays (3 x 1).  To continue, start a new task."Not sure where to go from here. 

 

if I go to EXTEND DESKTOP I can only extend onto the second DVI-connected monitor.  I see the DispalyPort adapted one but telling it to EXTEND DESKTOP to it does nothing.  If I go back to the CREATE EYEFINITY DISPLAY GROUP, it shows me now two monitors to select from, I select the base (#1) then it creates the display group again but I don't know where to go from here to get all three displays working.  

 

If I create the display group and then go to DESKTOP MANAGEMENT -> CREATING AND ARRANGING DESKTOPS - I see all three displays in the "Select a Display" area.  I can still only extend onto the DVI-connected display.  The other allows me to select "EXTEND" but when I do, nothing happens.  

 

any ideas?  Please help thanks



Edited: 08/17/2013 at 08:16 AM by krhen
 08/22/2013 11:53 AM
User is offline View Users Profile Print this message

Author Icon
Kent@AMD
Grinding Levels

Posts: 127
Joined: 01/10/2013

If the adapter was passive, you'd get an error saying that you had to disable one of the other monitors first. With that type of issue, where it does nothing, it would point towards either a hardware issue (bad adapter/cable) if it makes the changes on the software side (shows 3 monitors as enabled). If it just fails to apply the settings and just sits there like it did before, it seems more likely to be a software issue. Have you tried uninstalling/reinstalling the drivers, and testing that each monitor works independently?



-------------------------
AMD Customer Care

The information presented in this do*****ent is for informational purposes only and may contain technical inaccuracies, omissions and typographical errors. Links to third party sites are for convenience only, and no endorsement is implied.
Statistics
81149 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.