Topic Title: PC Desktop lags with all new drivers when 3 monitors are connected
Topic Summary:
Created On: 10/10/2013 09:48 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 10/10/2013 09:48 PM
User is offline View Users Profile Print this message

Author Icon
r9800pro
Peon

Posts: 1
Joined: 10/10/2013

Catalyst 13.4 WHQL was the last driver that worked fine. Any new driver, either beta or WHQL gives me the same issue

My PC lags horribly with all newer drivers! I mean the whole PC. Mouse movement lags, opening folders lags, moving/resizing windows lags and this is the first time ever I see such thing. That lag is very bad and consistent and I tried running a movie with MPC-HC with stats to check frame drops and indeed when moving mouse frames dropped like crazy! That didn't happen with 13.4 WHQL

I am running Eyefinity but tried disabling Eyefinity and ran 3x 1920x1080 monitors and both configurations have that lag thing. The issue disappears when I physically disconnect my other 2 monitors. It occurs only with Eyefinity enabled and with Eyefinity disabled but the 3 monitors are connected

I am on a single Asus HD 7970 GHz Matrix Platinum

I tried installing new drivers on top of old ones, fresh install with totally removing old ones and it is always the same issue

Specs:

Core i7 920
Asus Matrix Platinum HD 7970 GHz
Asus Rampage III Extreme
6GB Triple Channel OCZ Blade DDR3
3 BenQ 2420HD 1080p 24" Widescreen LCD in Eyefinity
OCZ Vertex 3 Max IOPS 120GB SSD + 15.0TB of HDDs
X-Fi Titanium-Cambridge SoundWorks DTT 3500 Digital
Seasonic X-850
Windows 7 64-bit
 

Any help would be much appreciated

 



Edited: 10/11/2013 at 12:51 AM by r9800pro
Statistics
87646 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.