Topic Title: HD7970 can't find 3rd screen after drivers update
Topic Summary: Eyefinity is ruined, im a cave man......
Created On: 02/19/2014 03:10 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 02/19/2014 03:10 PM
User is offline View Users Profile Print this message

Author Icon
Jocko
Peon

Posts: 1
Joined: 02/19/2014

Hey,

So i tried to start bf4 today but they told me i got some new drivers to download so i downloaded them, the beta verision. The screens vent black and i restarted the computer after 5 min and then the third screen didnt work. Restarted again and no diffrent. So i downloaded the regular drivers and no diffrence there either and ofc i restarted a couple of times nothing changes.

It have been working perfectly before this and Ive had no problems, i vent from regular standing eyefinity to vertical eyefinity for 2 weeks and i had no problem untill i installed these new drivers. Ive tried to download the old drives but i haven't managed them to work either.

 

It's a gigabyte 7970 with windforce 3x and im using both the minidp and the regular hdmi because it wouldnt work from the beginning with the dvi. What have happened?

 02/21/2014 12:29 PM
User is offline View Users Profile Print this message

Author Icon
Petersson
Peon

Posts: 2
Joined: 02/10/2014

I am not 100% certain, what the new patch did, but it something to eyefinity and 3 monitor setups.

On my HD7990 I've been running a 3 screen Eyefinity setup for 6 months using 3 identical mini DP active adapters and after the patch only 2 screens can managed through CCC.

CCC can see the 3rd monitor fine, it is just disabled. And it cannot be activated by any means.

I solved my issue by using a different mini DP adapter and suddenly I could use all 3 screens again. But that meant a return of the screen tearing that happens when you use different types of adapters. So for now I am happy to have 3 screens working again, but it is by no means a good fix, cause the screen tearing is horrible compared to before.

Setting up Eyefinity and the replacing the adapter with the old working one automatically removes the 3rd display from the eyefinity group.

My guess is that the new drivers (and 13.12 as well, tested that as well) look to the frequencies in each adapter to differentiate each screen, but if you have several identical adapters, it cannot differentiate between them and only use the standard 2 screens which can almost always be detected. Kinda dodgy description, so bear with me

It is solely an Eyefinity issue. But the problem persists after reformat/reinstall, so it must be driver related and something that worked pre 13.12 was removed in the subsequent drivers.

 03/21/2014 05:55 PM
User is offline View Users Profile Print this message

Author Icon
Maxakito
Peon

Posts: 1
Joined: 03/21/2014

Hi, i have same problem when i updated drivers. I have a 7970 and eyefinity setup works ok with catalyst 13.4 (and before), but no with the following versions. The monitor with the DP adapter it´s disabled in catalyst, and if i reinstall the 13.4 version all works well again. Any help will be appreciated. 



-------------------------
i7 2600K 3.4Ghz
Asus P8Z68-V-Pro
Ram 8Gb G.Skill Sniper DDR3 1866 PC3-14900
Sapphire Radeon HD 7970 Dual-X 3GB GPU 1060 Mem 1600
SSD Cruzial M4 256Gb + 5 discos SEAGATE 500Gb en RAID 0
3 Monitores 23" eyefinity
 03/26/2014 05:31 PM
User is offline View Users Profile Print this message

Author Icon
jingkun
Peon

Posts: 9
Joined: 03/26/2014

Well I don't know what help I'm going to be here because I never tried to use the hdmi on my cards.  I've had several 7970s including the windforce and when I've been running 3 monitors it always wanted me to use 1 dvi cable and 2 active mini-dp to dvi adapters for me to get 3 to work.  I'm on 14.2 beta right now and I haven't had any problems with my triple monitors since July.  Mind I can't comment on the 7990 problem up there.  Of course I'm also on windows 8.1 so that might throw a few things off for yall.

Statistics
87580 users are registered to the AMD Support and Game forum.
There are currently 0 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.