Topic Title: Eyefinity not working with MST HUB
Topic Summary: Triple Displayport monitor don't work with R9 290X and MST Hub
Created On: 08/27/2014 04:36 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/27/2014 04:36 PM
User is offline View Users Profile Print this message

Author Icon
Tarrill Harris
Peon

Posts: 2
Joined: 08/27/2014

I purchased a Club 3d Sense Vision 5300U to use with my ASUS R9-290X with Catalyst 14.4 connected to my three ASUS KV287Q Displayport monitors. The monitor are set to 1920 X 1080 at 60Hz refresh.
All of the monitor work in the Displayport mode when plug into the Displayport connector of the video card.  However, when I plug in the MST hub, I have no picture on the monitors, and get the following error message: Displayport link failed , The system has detected a link failure and cannot set the requested resolution and refresh rate on your DisplayPort Display.  Your display might not support the requested resolution or there may be an issue with the cable connecting the display to your computer.  Yet the monitors show up in the in the AMD Control Center DisplayPort-Diagnostic information tab.

I get the same reading- bandwidth 48% (from 20,76Gbps) with 2 ports used.  I only plug two monitors in for testing so I could see what was going by viewing the third monitor.

I have sent the above information to Club 3d requesting support.
Any thoughts?

 08/27/2014 11:41 PM
User is offline View Users Profile Print this message

Author Icon
zipsi
Elite

Posts: 1050
Joined: 11/22/2010

My biggest question right now is.. why would you even buy a MST hub if you can use ten times cheaper cables/adapters to drive these monitors. MST hubs are only really needed when you are trying to connect 4-6 monitors at a time.



-------------------------
Intel I7 3770K @ 4.5ghz, Cooler Master Hyper 212 Evo, Gigabyte Z77X-UD3H, Gigabyte HD7970 ghz edition, 4x4gb Kingston HyperX Beast 2133mhz, Seasonic Platinum 860, Samsung 840 Pro 256gb, OCZ Vertex 4 128gb, WD Black 1TB, WD Green 3TB+1.5TB, ASUS Xonar Essence ST, ASUS VE278Q, Windows 3.11
 08/28/2014 10:23 AM
User is offline View Users Profile Print this message

Author Icon
Tarrill Harris
Peon

Posts: 2
Joined: 08/27/2014

Thank you, And yes I am trying to run 6 monitors at one time.  I have already gotten 4 running with standard cables and the outputs of the card.

Statistics
86405 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.