Topic Title: Catalyst update problem (black screen)
Topic Summary:
Created On: 05/14/2013 12:50 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 05/14/2013 12:50 PM
User is offline View Users Profile Print this message

Author Icon
Aryssa
Peon

Posts: 2
Joined: 05/14/2013

I recently tried updating my drivers (and catalyst in the process) and whenever i go to do so, my screen turns black and won't come out of it.. the only way to see my screen after that is to run in safe mode upon restart. I`ve tried numerous things so far but nothing seems to have worked.. before 13.4 released  i tried to update and only got a BSOD, so i guess it's an improvement haha

 

1. Processor: AMD FX 4170 quad core 4.2ghz
2. Graphics card: 2 Radeon 6850HD SLI (crossfire)
3. OS: Win 7 64 bit
4. Driver version: 12.10
5. Power Supply: ThermalTake 800W 80Plus Bronze Active PFC PSU model TR-800p
6. RAM: 16gb
7. Did your computer come with the OS and Graphics card you have now? yes to both
8. Monitor resolution (native) and connection (DVI, HDMI, VGA, etc) : 1920x1080 on DVI

 05/15/2013 01:03 AM
User is offline View Users Profile Print this message

Author Icon
pissed2636
Peon

Posts: 20
Joined: 05/08/2013

got the same problem as u dude except with my crossfire 7970s
 05/15/2013 01:04 AM
User is offline View Users Profile Print this message

Author Icon
pissed2636
Peon

Posts: 20
Joined: 05/08/2013

what motherboard do u have?
 05/15/2013 04:46 PM
User is offline View Users Profile Print this message

Author Icon
Aryssa
Peon

Posts: 2
Joined: 05/14/2013

Originally posted by: pissed2636 what motherboard do u have?

 

Gigabyte.. uhh not sure specifics, model number GA-970A-UD3

 05/15/2013 11:52 PM
User is offline View Users Profile Print this message

Author Icon
pissed2636
Peon

Posts: 20
Joined: 05/08/2013

Gigabyte ahh i figured i to have a gigabyte ga-970a-d3 tho i believe the problem has to do with one of the pcie slots being pcie x4 rather than pciex16. i guarantee you can install the 13.4 drivers with only one card installed. take out one of the cards and install the drivers again if you can download the driver without a problem shut off the pc and install your second card. if you boot into a black screen then me n u r still stuck on the same boat
 06/01/2013 12:58 AM
User is offline View Users Profile Print this message

Author Icon
--Will--
Peon

Posts: 4
Joined: 06/01/2013

Did either of you have any luck with this? I am having the exact same problem but with 2 HIS IceQ 7870's. And I have the exact same motherboard.

No matter what I do, I can't seem to update the drivers. I can install the other parts of Catalyst separately (using Custom install) but whenever it I try the drivers, I get the blank screen issue. It's driving me nuts!

 06/05/2013 11:15 AM
User is offline View Users Profile Print this message

Author Icon
Marc@AMD
Forum Moderator

Posts: 774
Joined: 07/30/2012

There has been an on-going issue with Driver Installation on Crossfire systems since Catalyst 12.10.  Unfortunately, I am not aware of any work-around.  The more individuals that report this issue, the more visible the problem becomes to the driver development team. This aids in prioritizing the issue to be resolved in upcoming driver builds.

www.amd.com/report

;Marc



-------------------------

AMD Customer Care

The information presented in this document is for informational purposes only and may contain technical inaccuracies, omissions and typographical errors. Links to third party sites are for convenience only, and no endorsement is implied.

 06/06/2013 08:09 PM
User is offline View Users Profile Print this message

Author Icon
--Will--
Peon

Posts: 4
Joined: 06/01/2013

That link doesn't work...

 

EDIT: there seem to be some other errors going on with the AMD site just now, so I'll try it again later.

 

2nd EDIT: just found this link in Bing and used it instead since it is still working.



Edited: 06/06/2013 at 08:22 PM by --Will--
Statistics
84848 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.