Topic Title: AMD 970 chipset and crossfire
Topic Summary:
Created On: 07/15/2013 10:45 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 07/15/2013 10:45 AM
User is offline View Users Profile Print this message

Author Icon
malee
Peon

Posts: 5
Joined: 07/15/2013

Howdy!

I have been having an issue installing any graphics drivers higher than 12.8 when using crossfire. 

Specs:
GA-970A-DS3
Phenom x6 1090t
2x Sapphire 6850's
Win 7 64

After struggling and struggling I finally came across a helpful post on here: http://www.tomshardware.co.uk/forum/389647-33-catalyst-black-screen-bsod

It should be noted to everyone buying a 970 chipset board that crossfire does not work with any new drivers. Lots of 970 boards are still for sale with retailers!

I now have only 2 options:
1) stay on 12.8 with CF enabled
2) Removed one card and update to 13.4

Dissapointed!! 

 07/15/2013 11:11 AM
User is offline View Users Profile Print this message

Author Icon
black_zion
80 Column Mind

Posts: 12334
Joined: 04/17/2008

Let's see, the AMD 970 chipset has 2 PCIe slots which run in x16/x4, which is not suitable for Crossfire, so I don't see why you should be disappointed.

-------------------------
ASUS Sabertooth 990FX/Gen3 R2, FX-8350 w/ Corsair H60, 8 GiB G.SKILL RipjawsX DDR3-2133, XFX HD 7970 Ghz, 512GB Vertex 4, 256GB Vector, 240GB Agility 3, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, HP ZR2440w, Win 7 Ultimate x64
 07/15/2013 11:11 AM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7171
Joined: 11/13/2009

Drivers newer than 12.8 require the current netframework version. The correct version must be installed Before trying to install the drivers, not after.The article you referenced suggested disabling ULPS..FAQ article here.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

 07/15/2013 11:27 AM
User is offline View Users Profile Print this message

Author Icon
malee
Peon

Posts: 5
Joined: 07/15/2013

Originally posted by: black_zion Let's see, the AMD 970 chipset has 2 PCIe slots which run in x16/x4, which is not suitable for Crossfire, so I don't see why you should be disappointed.

That has nothing to do with it! Even in x16/x4 there is enought bandwidth for 2x 6850's. It runs BOTH at pcie 2.0 and not 1.1. Here is some testing I was doing last week with spare cards I had:

  4890       560ti  6850 @          16x     6850 @        4x card1         6850 @        4x card2 6850 cf 16x4x
Ice Storm 80396 97104 91770 88300 83336 98941
Cloud gate 10163 12948 11943 11904 11755 14780
Fire Strike   3055 2422 2374 2345 4125
3d Vangage            
H 6949   9350 9349 9066 15771
Tomb Raider 1920x1080   1920x1080 1920x1080 1920x1080 1920x1080
Min 27.2   35 33.9 34 44.7
Max 36   50 48.6 49.1 62.3
Avg 32.1   43.6 43 42.7 59.8


 With single cards the difference between 16x and 4x is minimal!

 07/15/2013 11:34 AM
User is offline View Users Profile Print this message

Author Icon
malee
Peon

Posts: 5
Joined: 07/15/2013

Originally posted by: stumped Drivers newer than 12.8 require the current netframework version. The correct version must be installed Before trying to install the drivers, not after.The article you referenced suggested disabling ULPS..FAQ article here.

 

Please read the article proplerly. Everyone with a 970 chipset is having issues when installing 13.x drivers with crossfire.

If I insall 12.8 it works fine, if I install 13.4/13.6beta with a single card it works fine, the moment I connect the second card it wont go into Windows. One of the guys on there suggester disabling ULPS as a solution which doesnt help! Look at pages 5 and 6 and you will see people quoting AMD support replies where AMD accept that there is an issue with 970 chipsets and crossfire with all of the 13.x versions.

I wonder when this driver issue will be fixed?
 07/21/2013 07:47 PM
User is offline View Users Profile Print this message

Author Icon
KeepersWay
Peon

Posts: 4
Joined: 03/14/2013

Been having this issue for a long time myself and there is no fix I even call AMD and they tell me to revert to drivers before 13.x, quite disssapointed.

 

 

Statistics
84704 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.