Topic Title: 7990 Crossfire issues
Topic Summary: Games don't work all that well under crossfire conditions.
Created On: 09/13/2013 07:20 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 09/13/2013 07:20 PM
User is offline View Users Profile Print this message

Author Icon
AlecTalon
Peon

Posts: 3
Joined: 09/05/2013

So, I built a new computer from scratch, and I'm having issues with my Video Cards. I've got 2 XFX Radeon 7990's set to Crossfire. Most of the games I play are having issues. Even games that are supposed to be optimized to AMD Cards are having problems. I'm getting random drops of FPS on Bioshock Infinite, Ground/Texture Flickering on Battlefield 3, and a whole slew of problems with Final Fantasy 14. A lot of my other games are having issues as well. I thought the Beta Driver would fix it, but nothing really happened. 

 

On DOTA 2 and Final Fantasy 14, everything is okay until I hover over an object. When I do, the FPS drops like a freaking rock. I have no idea what would could be causing this. 

The rest of my Rig is as Follows:

 

Windows 8 Pro 64 Bit Edition

Intel Core i7 4770k @ 3.50 GHz

8.00 Dual Channel DDR3 Ram (However, for some reason it's at 800MHz when it should be at 2400)

MSI Z87 XPower (MS-7811) Motherboard

1TB Seagate HD

Sound Blaster 7 

Any help would be appreciated. I'm getting tempted to return these two cards for 2 GTX 780s. 

 

Thanks!

 09/17/2013 03:16 AM
User is offline View Users Profile Print this message

Author Icon
deathcrush87
Grinding Levels

Posts: 170
Joined: 08/17/2013

hi mate, im no expert but i heard and experienced negatively with xfx products. the xfx brand for nvidia chipsets is gainward which is one of the cheapest one can find. 

xfx used to be good but now comparing to other brands such as gigabyte, msi, vtx3d and asus they are not as good.

i might be wrong though...



-------------------------

AMD FX8350//Corsair vengeance DDR3 CL9 8GB@1600//Asus ROG Crosshair V Formula z//Asus R9 290X oc DCII//Corsair CX750//Razer Lycosa//Corsair M30//Zalman Z11 plus case//Kingston 120gb SSD//Yamaha Audiogram6//Windows 8.1 64bit//

 09/17/2013 03:36 PM
User is offline View Users Profile Print this message

Author Icon
UcouldBrong
Overclocker

Posts: 797
Joined: 01/05/2013

Yes,  @death... UcouldBrong...XFX works fine.

 

@Alec...Uhhh...heat?? 

 

You may want to optimize memory settings in your mobo's menus.

 

 



-------------------------

 


 


Non-noob components.

 09/17/2013 05:13 PM
User is offline View Users Profile Print this message

Author Icon
black_zion
80 Column Mind

Posts: 12332
Joined: 04/17/2008

Having strayed from Sapphire for the first time in many years with this XFX 7970, I can say that I will not choose them for my next build. Between the excessive coil whine and the fact I had to spend $15 return shipping to RMA the card not a month after I got it because the card failed (a common issue with that model according to XFX) I would not recommend them.

As for your problem, it sounds like either insufficient power, incorrect graphics card placement, and/or insufficient cooling/airflow. As for your memory problem, most motherboards default to a failsafe loose timings low speed state when new RAM is installed. You need to set it manually according to the manufacturers specs.

-------------------------
ASUS Sabertooth 990FX/Gen3 R2, FX-8350 w/ Corsair H60, 8 GiB G.SKILL RipjawsX DDR3-2133, XFX HD 7970 Ghz, 512GB Vertex 4, 256GB Vector, 240GB Agility 3, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, HP ZR2440w, Win 7 Ultimate x64
 09/17/2013 11:04 PM
User is offline View Users Profile Print this message

Author Icon
UcouldBrong
Overclocker

Posts: 797
Joined: 01/05/2013

Huh?....bought two of the earliest TDBC versions and have only had cool, quiet and trouble-free HIGH PERFORMANCE satisfaction with them!  HIGHLY RECOMMENDED!

-----------------------------------------------------------------------------------

Would definitely keep the 7990s!  Drivers are SLOWLY maturing.  Cooling/airflow paramount.

*No power supply wattage on your build noted.*

If I had your Z87, I'd upgrade to a 3 x Samsung 840PRO 256Gb array in RAID 0 and use the Seagate as storage.

You have a monster rig!



-------------------------

 


 


Non-noob components.



Edited: 09/17/2013 at 11:24 PM by UcouldBrong
Statistics
84699 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.