Topic Title: Poor FPS Using AMD A10-5800k with 6670
Topic Summary: Trouble getting decent FPS in alot of games.
Created On: 09/21/2013 07:09 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 09/21/2013 07:09 AM
User is offline View Users Profile Print this message

Author Icon
RVTGuts
Peon

Posts: 5
Joined: 09/21/2013

So a few months back i bought a AMD A10-5800k and a XFX HD 6670 Radeon 1GB. So I have tried many different drivers. Currently im on 13.9 Catalyst Control Center I believe the newest one. But i have tried many games and alot of them i have to play on low settings. Portal 2 i can max out and Killing Floor and a few others BUT Saints Row 3/4 i can only play on low with out major FPS lag. Battlefield bad company 2 I have to play on Medium to get good FPS. I had gotten Assassins Creed 3 as a gift recently and even with the settings on the lowest *medium* i get horrible FPS to the point i can not play it at all. I have heard and seen people with the same build as i have and they get so much more FPS then i do. Please i would like some help to fix this issue. Do i need a different driver, do i need to contact amd get different parts. Please help. Im starting to regret making a GPU crossfire build. I have my monitor pluged into the onboard. I have also upgraded my ram and when i check it my CPU sits at about 58% usage while gaming. So please advice help something would be appreciated.

 

My pc specs are: 

Processor: AMD A10-5800k 3.8 GHx *not overclocked*

Video card: XFX Radeon HD 6670 1GB

Board: ASROCK FM2 amd

Ram: G. Skill Ripjaws 2 X 4GB *8GB total*

PowerSupply: 750 Watt

Windows 7 Ultimate 64 Bit Service Pack 1

 09/21/2013 11:47 PM
User is offline View Users Profile Print this message

Author Icon
WMudrockJr
Overclocker

Posts: 705
Joined: 04/01/2013

Please tell me what your 3D Application Settings are under the Gaming Tab.



-------------------------

AMD A10-5800K, XFX 7850 Ultra OC Edition 975MHz, 16GB RAM, Win 8.1 Pro 64 bit, MSI 7778 motherboard, 500W PSU, HP P7-1235, CCC 13.12 WHQL

 09/22/2013 12:09 AM
User is offline View Users Profile Print this message

Author Icon
RVTGuts
Peon

Posts: 5
Joined: 09/21/2013

Anti Aliasing Mode: Use application settings

Anti aliasing samples: Use application settings

Filter: standard

Anti aliasing method: multisampling

Morphological Filtering: off

Anisotropic filtering Mode: Use Application settings

Anisotropic Filtering Level: Use Application Settings

Texture Filtering Quality: Performance

Surface Format Optimization: Off

Wait for Vertical Refresh: Always off

OpenGL Triple Buffering: Off

Tessellation Mode: Use application Settings

Maximum Tessellation Level: Use application Settings

 

 09/22/2013 12:20 AM
User is offline View Users Profile Print this message

Author Icon
WMudrockJr
Overclocker

Posts: 705
Joined: 04/01/2013

I have the following differences in my settings.

Texture Filtering Quality:Standard

Wait for Vertical Refresh: Always off, unless application specifies

OpenGL Triple Buffering: On

This gives me the best performance in old and new games.



-------------------------

AMD A10-5800K, XFX 7850 Ultra OC Edition 975MHz, 16GB RAM, Win 8.1 Pro 64 bit, MSI 7778 motherboard, 500W PSU, HP P7-1235, CCC 13.12 WHQL

 09/22/2013 12:27 AM
User is offline View Users Profile Print this message

Author Icon
RVTGuts
Peon

Posts: 5
Joined: 09/21/2013

I set mine the way you have yours. Launched Saints Row 4 and told it to auto detect and ran it. It was still horrible. I don't know what to do i feel like I waisted my money or maybe the parts are bad or messed up. I am not sure but its very dissapointing.

 09/22/2013 01:09 AM
User is offline View Users Profile Print this message

Author Icon
WMudrockJr
Overclocker

Posts: 705
Joined: 04/01/2013

Are you using the CAPS 13.5 with your Dual Graphic setup. 

I'm not a big fan of Dual Graphics/CrossFire setup that is why I have a 7850.

I do take a hit when I mess with the Texture Filtering Quality by changing from Standard to Performance.



-------------------------

AMD A10-5800K, XFX 7850 Ultra OC Edition 975MHz, 16GB RAM, Win 8.1 Pro 64 bit, MSI 7778 motherboard, 500W PSU, HP P7-1235, CCC 13.12 WHQL

 09/22/2013 01:39 AM
User is offline View Users Profile Print this message

Author Icon
RVTGuts
Peon

Posts: 5
Joined: 09/21/2013

Yes i have it installed. Still no help. Haha See my problem i been having. Can't figure it out. Not sure if i should call amd and talk find out whats going on. Cause i have already submited a ticket about a week ago.

 

 09/22/2013 01:51 AM
User is offline View Users Profile Print this message

Author Icon
black_zion
80 Column Mind

Posts: 12371
Joined: 04/17/2008

Going to sound like a stupid question, but are Dual Graphics enabled?

-------------------------
ASUS Sabertooth 990FX/Gen3 R2, FX-8350 w/ Corsair H60, 8 GiB G.SKILL RipjawsX DDR3-2133, XFX HD 7970 Ghz, 512GB Vertex 4, 256GB Vector, 240GB Agility 3, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, HP ZR2440w, Win 7 Ultimate x64
 09/22/2013 01:54 AM
User is offline View Users Profile Print this message

Author Icon
RVTGuts
Peon

Posts: 5
Joined: 09/21/2013

Yes Dual Graphics are enabled. Thank you for the suggestion though.

 09/22/2013 05:31 AM
User is offline View Users Profile Print this message

Author Icon
deathcrush87
Grinding Levels

Posts: 170
Joined: 08/17/2013

hi mate, 

im no expert at all, but try to go to power options, choose "high performance" instead of "balanced", also with "high performance" selected click change plan settings, then click on change advanced power settings, go to pci express section>link state power management and set the setting to "off".

also search this forum for "ulps" and how to disable it, hopefully it will help you.

on the other hand i have to say that your card does not look that powerful, so do not expect much.



-------------------------

AMD FX8350//Corsair vengeance DDR3 CL9 8GB@1600//Asus ROG Crosshair V Formula z//Asus R9 290X oc DCII//Corsair CX750//Razer Lycosa//Corsair M30//Zalman Z11 plus case//Kingston 120gb SSD//Yamaha Audiogram6//Windows 8.1 64bit//

 09/22/2013 05:39 AM
User is offline View Users Profile Print this message

Author Icon
deathcrush87
Grinding Levels

Posts: 170
Joined: 08/17/2013

hang on a second mate... you do have a xfx 6670 and you have another 6670 onboard? im not sure if it is classed as crossfire....

plug your monitor to your xfx, but then it wont be a real crossfire, as you need to have 2 graphics card with the exact same specs and they should be connected to each other with a crossfire bridge.

 



-------------------------

AMD FX8350//Corsair vengeance DDR3 CL9 8GB@1600//Asus ROG Crosshair V Formula z//Asus R9 290X oc DCII//Corsair CX750//Razer Lycosa//Corsair M30//Zalman Z11 plus case//Kingston 120gb SSD//Yamaha Audiogram6//Windows 8.1 64bit//

Statistics
84907 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.