Topic Title: problems with frame rates in all games
Topic Summary:
Created On: 10/24/2013 04:30 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 10/24/2013 04:30 PM
User is offline View Users Profile Print this message

Author Icon
suicidinsoul
Peon

Posts: 1
Joined: 10/24/2013


Graphics Card
2x AMD Radeon HD 5900 series

AMD Catalyst Driver Version, and Driver History
currently beta 13.11 tried 13.9 and 13.10 beta problem after trying to update from 13.8

Operating System
windows 7 64 bit service pack 1

Issue Details

so with playing rome 2 total war with the 13.8 drivers i ran into a few problems so i thought id update the drivers to the 13.9 drivers, but the drivers wouldnt install i kept getting BSOD even after a clean uninstall following the gpu-57 page of the prev drivers so i attempted to install the 13.10 beta drivers

The installation went through but got failed to complete installation. After reading the log it said the video drivers didnt install but everything else did so again i did a clean uninstall of the amd software in control panel again attempted the installation again and it all went through fine.

but all my games that ran smoothly are constantly getting frame drops. so when the 13.11 beta drivers came i went to uninstall the 13.10 drivers where it actually BSOD during the uninstall process. ran uninstall second time and it worked fine but even after doing a clean install of the 13.11 beta drivers im having frame rate issues

ive tried multiple times to install the 13.9 from clean install but it BSOD everytime so i cant seem to downgrade. i have also gone into safemode/msconfig to disable all my programs running in background to make it wasnt any programs(avast wouldnt disable in msconfig if not in safemode) my windows is uptodate currently.

and after looking into my dxdiag it saying my driver version is 13.200.16.0 which doesnt seem right to me

anythoughts i can go through?


Applications and Games

all games no problems befor update

mostly League of lengends rome 2 total war world of tanks (all ran smoothly untill update except rome 2 with is common issues at the time)

Additional Details

ran virus scan with avast and malwarebytes to ensure no issues and all came up clean

Statistics
87566 users are registered to the AMD Support and Game forum.
There are currently 7 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.