Topic Title: R9 290X Crossfire Audio and Performance Issues (Beta Driver)
Topic Summary: (Distortion found only in 13.11 Beta v9.4 from 11/22)
Created On: 12/01/2013 02:35 PM
Status: Post and Reply
Linear : Threading : Single : Branch
1 2 Next Last unread
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 12/01/2013 02:35 PM
User is offline View Users Profile Print this message

Author Icon
sporkotica
Peon

Posts: 2
Joined: 11/28/2013

When I installed the Catalyst drivers 13.11 betav9.4 I began to experience a very odd audio distortion - it would not occur when a 3D Game was active on screen, or just the desktop was visible. If I loaded a "2D" game, for lack of a better word, it would instantly cause massive audio distortion - digitized, playing slower - sounding enormously corrupted, basically.

A couple scenarios;

-Start playing music (Zune), plays fine. Open and run Final Fantasy XIV (full screen), audio plays fine. Alt-Tab out to desktop, audio becomes wildly distorted and the mouse cursor begins behaving poorly, as though it's a few frames off. Disabling music still causes "slow" performance, and all audio (videos, music, etc) plays distorted UNTIL I alt-tab back to the FFXIV window.

--Repeat this same scenario in Borderlands 2, seems to behave the same.

 

-Start playing CastleStorm, audio is utterly distorted, game crashes when I go to display settings.

--Start playing Hex Alpha, same result.

 

This issue -does not- occur on the older beta versions for Drivers/CCC or when Crossfire is disabled.

 

GPU: 2x Sapphire Radeon R9 290X

CPU: Intel i7 4770k

Motherboard: Asus Maximus VI Hero

Audio: Onboard

Ethernet: Onboard

RAM: 16GB G-Skill RipJaws DDR3-2133

Hard Drive: 180GB Corsair Force 3

OS: Windows 8.1 64-Bit

 

There are no other add-in cards in my system. This is frustrating, because 9.4 cures the blackscreen crash, but renders me unable to play all my games or utilize them and the rest of my system fully if they do work.

 12/09/2013 10:09 AM
User is offline View Users Profile Print this message

Author Icon
Sherp
Peon

Posts: 1
Joined: 12/09/2013

I'm having the exact same isue as you with 9.4 ! I've tried using both my onboard and external soundcard. I even went as far as reinstalling Windows as I convinced myself it was my soundcard causing the problem. It wasn't until I disabled crossfire in CCC that I found the source of the problem.

This issue mainly occurs in Borderlands 2 and Assassins Creed 4. Borderlands 2 is playable, but the audio is not. AC4 crashes within a few minutes of playing.

2x R9 290(non X)

 12/13/2013 03:36 AM
User is offline View Users Profile Print this message

Author Icon
MagicPants
Peon

Posts: 2
Joined: 12/13/2013

I'm hearing the same issue, (just updated to 9.5 and it's still there). I've heard it in Saints Row IV and Skyrim, so far.

I have two 290x's in crossfire. Whenever crossfire isn't disalbled the audio starts to crack up, though I think it just effects streaming audio (in game music). I remember it working fine before 9.4.

For a while, I thought it was my x-fi, but it only crackles while playing games, and then only in crossfire.

I'm running windows 7 64-bit.

Seems like this driver is stomping on or bottlenecking the audio data to the sound device. If I had to guess, I'd say they are hogging all the pci-e bandwidth for the new bridgeless xfire, and not allowing audio data to go through.

 12/13/2013 10:30 AM
User is offline View Users Profile Print this message

Author Icon
Ray@AMD
Forum Moderator

Posts: 124
Joined: 07/30/2012

Thanks for the feedback guys.

We're looking into the issue.



-------------------------

AMD Customer Care


The information presented here is for informational purposes only and may contain technical inaccuracies, omissions and typographical errors. Links to third party sites are for convenience only, and no endorsement is implied.

 12/15/2013 07:41 PM
User is offline View Users Profile Print this message

Author Icon
Skinner
Peon

Posts: 25
Joined: 12/22/2007

I also have and reported the issue, but only when games are running in crossfire. Driver 9.2 beta was fine, besides the blackscreens.

I'm using win 8.1 64 bit, a 4770K cpu, the same motherboard and an X-Fi soundcard.

 

I discovered it only happends with v-sync! Perf. is degreased massively too.

Also perf. without v-sync in some games goes up and down (even when not moving ingame), COD Ghosts and Splinercell Black list for example.

Allmost everybody have this issue, see hardOCP and Overclocknet. I cann't believe this passed the quality and control.....

 

 



Edited: 12/15/2013 at 08:08 PM by Skinner
 12/18/2013 06:24 PM
User is offline View Users Profile Print this message

Author Icon
MagicPants
Peon

Posts: 2
Joined: 12/13/2013

And yet the problem found it's way into the release drivers?

 

Originally posted by: Ray@AMD Thanks for the feedback guys.

 

We're looking into the issue.

 

 12/19/2013 04:02 PM
User is offline View Users Profile Print this message

Author Icon
Skinner
Peon

Posts: 25
Joined: 12/22/2007

Originally posted by: MagicPants And yet the problem found it's way into the release drivers?

 

 

 

Originally posted by: Ray@AMD Thanks for the feedback guys.

 

 

 

We're looking into the issue.

 

 

 

 

 

Yep, they relased the 13.12 whql with this issue..unbelievable...So another 4 weeks without functioning videocards....Unless a magical beta appears which solve this..

 12/21/2013 05:45 PM
User is offline View Users Profile Print this message

Author Icon
eldarko
Peon

Posts: 15
Joined: 12/21/2013

Same issue here (issue nr 1). Issue nr 2 is definitely a driver issue though...

http://forums.amd.com/game/messageview.cfm?catid=454&threadid=170337&enterthread=y

 

 12/26/2013 05:12 AM
User is offline View Users Profile Print this message

Author Icon
Sack
Peon

Posts: 4
Joined: 12/26/2013

Same problem here.

Win7 64, 2 x R9 290, 3 x Asus VG236 Monitors, Catalyst 13.11
Audio sounds like listening through a pipe, skipping 'frames'.

Skyrim (6048x1080):
Crossfire enabled and disabled - Audio problem
No problem at 1920x1080

Battlefield Bad Company 2 (6048x1080):
Crossfire - Audio problem
Crossfire disabled - Audio perfect

 



-------------------------

i7 2600K @ 4428Mhz | Asus p8z68 Deluxe | 8GB RAM | 2 x Gigabyte R9 290 | X-Fi Ti | 5TB | Silverstone Strider 1500W | SilverStone FT02B Fortress | Win7 64bit | ASUS VG236H 23" 3D LCD x 3 | Logitech G19 KB and G9 Mouse

 12/28/2013 11:55 AM
User is offline View Users Profile Print this message

Author Icon
Skinner
Peon

Posts: 25
Joined: 12/22/2007

Is there any hope AMD understand what's happening??? I have had it almost 1,5 month now..They don't seem to learn that things have to chance to keep youre ultra enthousiasts happy. A word, a fix, say something to regain faith... I almost fear the 14.1's will have this again....

 

Btw, its not all doom and gloom, the performance and IQ in games is outstandig with v-sync off. I'am keeping these GPU's fo sure!



Edited: 12/28/2013 at 10:23 PM by Skinner
 12/28/2013 11:52 PM
User is offline View Users Profile Print this message

Author Icon
dk001dank
Peon

Posts: 1
Joined: 12/28/2013

Hi all,

Here is the solution,

In your BIOS go to “precision timing” or similar and disable it!

Also disable V-sync.

I work on this for a whole day, even trying to use Xi-Fi analog card and got the bug under any settings.

My system is: 4K TV, 2x290x, Asus P9X79 i7 3820, Onkyo 3009 receiver.

You will get this bug in crossfire with any connection even when the speakers are the TV speakers.

AMD QA department are not smart enough to play games in crossfire?

 

This should be fixed since everything worked perfect with my previous cards Geforce 680x2 SLI.

 

 12/31/2013 06:16 AM
User is offline View Users Profile Print this message

Author Icon
serys
Peon

Posts: 26
Joined: 11/12/2013

Hi,

I have the same problem. I tried everything and the sound is ok only when I disable crossfire or V-sync. I tried with some games. In Splinter Cell Blacklist, I have to play in DirectX 9 and disable V-sync if I want good sound in crossfire. I hope they will fix this problem soon because I will put watercooling on 3 290x tomorrow and I won't be able to play without problem for now...

 

 01/08/2014 04:27 PM
User is offline View Users Profile Print this message

Author Icon
KillerKollar
Peon

Posts: 11
Joined: 10/22/2008

I have audio issues with my 290X Crossfire too.If i disable one card,it goes away.If i disable Vsync it's ok,and i don't use vsync in games becouse of the 60 fps limit,but for example there is skyrim when you CAN'T turn Vsync off and the audio...horrible.

 01/12/2014 11:57 PM
User is offline View Users Profile Print this message

Author Icon
kabalan
Peon

Posts: 1
Joined: 01/12/2014

same boat here.

 

running 290x crossfire. 

running eyefinity and when im on full screen mode game is fine

no lag no issue. but if somehow i decide to search the browser and tab out

hell will start. 

cant even watch video on youtube because the audio is terrible,

system is slowing down. mouse pointer got a slow mo delay. at first you wont notice it but when you start to play a video or another game it will totally slow you down.

but when i go back to the orriginal game i tab out while playing a video on youtube behind sound will go back to normal. as in normal.

all this problem will go away when i dissabled crossfire mode.

another solution i found is fresh install and no windows update at all.

i tried this on 3 different OS and the same issue appearing.

WIN 8 pro Win 8.1 PRo and window 7 ultimate. all legit OS btw.

 

hope there is an update to fix this cuz i dont want to left behind thinking i have a bunch of update i didnt install.

 02/02/2014 12:08 AM
User is offline View Users Profile Print this message

Author Icon
sporkotica
Peon

Posts: 2
Joined: 11/28/2013

This issue continues and is extremely annoying. It has been in every single subsequent driver release since at least 13.11 v9.4 and up. This is in literally every single driver release, including the final release of 13.12 and now the beta of 14.1.

 

Disabling vSync does exactly nothing, either disabling it at the driver level or at the application level, or both. The audio corruption continues and it is incredibly, ridiculously annoying.

 02/02/2014 09:59 AM
User is offline View Users Profile Print this message

Author Icon
reedy777
Peon

Posts: 1
Joined: 02/02/2014

I'v had the same issue with 290's and 290x setups in xf

reduces fps and creates audio distortion crakling skipping etc. diabling vsync in game fixes the problem crysis 3 with vsync on is 40 fps  with vsync off its sits above 60 maximum lows of 55 fps with no audio distortion. same exact symtoms with bf4, MLL and other games my system is

win 7 64 ultimate

2600k @ 4.8

corsair vengemce 1600mhz x 8gb

maximus V extreme

2x240 gb sandisk extreme in raid 0

be quiet dark power pro 1200w psu

2x 290x reference msi bf4 ed

cards installed pcie 1 native and pcie 3 via plx chip. i have tried the cards in pcie 1&3 native but returned it to 3 via plx as this was not the cause of the proble on my rig.

final note i do have a razer headset that are renowned for driver issues but with it unpluged sames issues but its worth mentioning in case of a trend

 

 

 

 02/02/2014 02:47 PM
User is offline View Users Profile Print this message

Author Icon
serys
Peon

Posts: 26
Joined: 11/12/2013

I have one thing to say for AMD. I waste my money to buy 3 cards R9 290x and for watercooling because the too high temperature. I will sell that, probably nobody will want that but I will try. Problem only problem... You cannot do the things in the right way. 3 months of *****. Sorry but I'm probably not the one who think that. My regrets are that I should have waited for the GTX 780 ti really...

 02/02/2014 03:52 PM
User is offline View Users Profile Print this message

Author Icon
Diwrnach
Peon

Posts: 4
Joined: 02/02/2014

290x in crossfire, with vysnq terrible crackling sound, drives me nuts, makes games like skyrim unplayable as you can't diasble vsynq.

 02/03/2014 12:17 AM
User is offline View Users Profile Print this message

Author Icon
Kourd
Peon

Posts: 1
Joined: 02/03/2014

2 Asus stock 290x's Crossfire

Intel i7-3930k with Intel MB

Soundblaster ZxR

Win 8.1 64

Same exact problems everyone else is listing.  ULPS set to 0 in registry (keeps second card powered on even when not in use.  It's supposed to help with Crossfire in general.  Google it if interested). 

I'm pretty much better off yanking the second card out of the system for now till this is sorted.  I've tried every combo of having vsync on / off + frame pacing on / off and I always get the crackle unless vsync is off.  Since I'm mainly playing Skyrim right now, that's not much help as vsync seems to always be on.  True even if changing settings in the ini file. 

Edit - Just read that turning off frame pacing in the driver for R9 cards doesn't necessarily turn it off, since it's handled by the hardware as well.

At any rate, hoping to see a fix soon.  The mantle beta drivers didn't have a fix.  Not that I was expecting it, just stating. 

Btw, I'd be interested to know if anyone has a 290 crossfire setup with a Creative card that doesn't have this issue.  I'm suspecting certain MB combinations don't suffer from it.

 02/05/2014 12:18 PM
User is offline View Users Profile Print this message

Author Icon
MajorEpeen
Peon

Posts: 3
Joined: 01/25/2014

AMD are obviously far too busy with mantle to fix the Crossfire Vsync issue.

Still using 13.11 beta v9.2 which does not have this issue but it sucks using such an old driver since so many other issues have been fixed since.

Could not find this driver on the AMD site but they had it over at Guru3D if anyone else is looking for it.

Statistics
85482 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.