Topic Title: x2 ATI HD6950 Crossfire - Missing Crossfire in CCC/Device listed as disabled
Topic Summary:
Created On: 12/07/2013 07:21 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 12/07/2013 07:21 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 3
Joined: 12/07/2013

Hello all!

I am recently the proud owner of two great cards; I managed to find another HD 6950 and got a new mother board and crossfired them together. Everything was working somewhat right in CCC 13.9. I had the crossfire option showing and enabled.


I upgraded to 13.11 last night because with my setup, even on single card mode, 13.9 was just not doing justice to my graphics, and 13.11 really boosted the quality.

After upgrading to 13.11 I have gotten a better optimized GPU, but no Crossfire option. Also in the hardware section of CCC, it lists my secondary driver as disabled.


I've tried everything. Complete uninstall - safe mode - driver sweeper then reinstall after several reboots in between those steps. I still cannot get it to come up. Not only that, I'm convinced that my performance has dropped slightly from the first instance I installed 13.11 to the constant uninstalls and reinstalls I ran.


I play MWO and was getting 60+ frames, now getting about 50+ frames on 13.11


Ok so sorry for the long post but the gist of it is; I want my xfire option to come back with these new drivers. Both cards work properly, both showing in Device manager and both showing as working on 13.9.


I'm currently running;


windows 7 Pro 64bit

900w PS

x2 HD6950 2GB

4th gen i5


93071 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.