Topic Title: Crossfire stops working with Catalyst & latest drivers (2x HD 7850)
Topic Summary: Any version of Catalyst above 13.9 disables my Crossfire set up, need help!
Created On: 02/06/2014 05:21 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 02/06/2014 05:21 PM
User is offline View Users Profile Print this message

Author Icon
aj_nolan
Peon

Posts: 1
Joined: 02/06/2014

I am running a Crossfire setup using 2 x Asus Radeon HD 7850 on a ASUS P8Z68-V LX motherboard.

For many months I have been happily running quite an effective Crossfire setup.  Recently, however, as a result of a request from the ever updating BF4. I upgraded my Catalyst software to 13.12.  As soon as the update was complete I ran 3DMark to see what effect, if any, the new drivers had made.

To my horror only 1 of my 7850's was being recognised and my scores had dropped significantly.  I then ran Catalyst and all options relating to Crossfire had gone.

I rolled the drivers back and everything went back to normal.  I really want to use the new drivers as eventually I hope to use the Mantle API with BF4.

Has anyone had a similar issue?  Can anyone help?  I have already raised a help desk ticket.

 02/07/2014 06:01 AM
User is offline View Users Profile Print this message

Author Icon
robad
Peon

Posts: 13
Joined: 02/02/2014

Sure, same theme is here http://forums.amd.com/game/messageview.cfm?catid=475&threadid=171407&enterthread=y

Statistics
86373 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.