Topic Title: R9 290x in Crossfire having severe performance issues
Topic Summary:
Created On: 02/16/2014 03:56 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 02/16/2014 03:56 PM
User is offline View Users Profile Print this message

Author Icon
voigt
Peon

Posts: 3
Joined: 02/16/2014

Anytime I enable crossfire on the R9 290x my frames per second drop considerably (15-20fps) in all games that I have tried. I get micro stuttering as well as sound stuttering until I disable both crossfire and vsync.

I was using Catalyst 13.xx but just installed the latest 14.1 beta 1.6 and the issue persists.

In single card mode I get 60-80fps in most games, Battlefield 4, Planetside 2, Final Fantasy 14, etc.  Soon as I enable Crossfire its choppy and runs at 15fps.  Is AMD even looking into these reports as I have been lurking for months on this issue but now I decided to make an account and post as well. 

I have yet to be able to use Crossfire at all with these cards and feel like I wasted $550 by buying a second one. I am still waiting for AMD to support their product but im starting to think I just need to get a refund and go back to nvidia...

 

Windows 7 64bit
Asus P8Z77-v CrossfireX
R9 290X in Crossfire

 02/16/2014 05:14 PM
User is offline View Users Profile Print this message

Author Icon
black_zion
80 Column Mind

Posts: 12870
Joined: 04/17/2008

Expansion Slots

PCI Express 3.0 x16 - 2 (x16/0 or x8/x8)
PCI Express 2.0 x16 - 1 (@x4)

Sure you have them in the 3.0 slots?

-------------------------
AMD FX-8350 w/ Corsair H105, ASUS Sabertooth 990FX Gen3/R2, 8GiB G.SKILL DDR3-2133, XFX HD 7970, 512GB Vertex 4, 256GB Vector, 240GB Agility 3, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, Corsair C70, HP ZR2440w, Win 7 Ultimate x64
 02/16/2014 05:31 PM
User is offline View Users Profile Print this message

Author Icon
voigt
Peon

Posts: 3
Joined: 02/16/2014

I just rebooted to verify, PCI Express link speed is set to 8x on both slots in use.

 02/16/2014 05:36 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7416
Joined: 11/13/2009

Have you disabled ULPS?

http://forums.amd.com/game/categories.cfm?catid=444&flcache=8780014&entercat=y



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 


 


 *  Quando Omni Flunkus, Moritati *

 02/16/2014 05:59 PM
User is offline View Users Profile Print this message

Author Icon
voigt
Peon

Posts: 3
Joined: 02/16/2014

Thank you, that solved half my issue.  Disabled ULPS in the registry and restarted, I now can run games with crossfire on but vysnc still causes stuttering and sound issues, turning off vysnc and now I am seeing 120-150fps in Planetside 2.

Statistics
87438 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.