Topic Title: Enabling Crossfire with dual HD 7970's causes games to crash
Topic Summary:
Created On: 02/18/2014 02:29 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 02/18/2014 02:29 AM
User is offline View Users Profile Print this message

Author Icon
TigerOnTheProwl
Peon

Posts: 4
Joined: 02/18/2014

Quite recently I built a fish tank computer.  My entire system (other than HDD) is submerged in mineral oil.  Since I wanted to build an extremely powerful gaming pc, I bought 2 Sapphire HD 7970 vid cards and have linked them with Crossfire, but I have run into a few issues.  With every game I have tried so far, I have discovered that sooner or later it will crash and my computer will stall.  It only happens when I have Crossfire enabled.  It doesn't blue screen, it just freezes and I can't do anything but hold the power button until it shuts off.  I have the latest drivers for all of my hardware.  And I'm sure that nothing is overheating as the highest temperature I recorded with Speccy is only 36*C.  I've also discovered that with some games, if I change my CCC to run the game with a different Crossfire profile, it can work.  For example, if I run Final Fantasy 14 with the profile for Fear, it will work indefinitely.  But if I run it on the default profile, it will crash within 5 minutes.  What's going on?  Does anyone have any idea how I can fix it?

Thanks in advance. 

 02/18/2014 04:35 AM
User is offline View Users Profile Print this message

Author Icon
UcouldBrong
Case Modder

Posts: 811
Joined: 01/05/2013

No offense, but could you fill us in on what "...an extremely powerful gaming pc" equates to and what "sooner or later it will crash" means in finite terms.

Have you attempted to run it with NO PROFILES selected?

 

P.S.  Get an SSD to make your PC....more powerful.



-------------------------

 


 


Non-noob components.

 02/18/2014 05:18 AM
User is offline View Users Profile Print this message

Author Icon
TigerOnTheProwl
Peon

Posts: 4
Joined: 02/18/2014

Sorry.  I should have added more details.  My hardware is as follows:

PSU: Cooler Master Silent Pro Gold 1200W

CPU: Intel i7 4770K (overclocked)

Mobo: Asus Sabertooth Z87

Ram: 64 gigs of Kingston (4 sticks of 16)

OS: Windows 7 Professional

 

As for when the games stall, it varies from one game to the next.  Crysis 3 for example will last about 30 seconds, but I can get roughly 2 hours from Diablo 3.  

I normally don't select any particular profile unless I've read of a particular game running better with a certain profile. 

 02/18/2014 03:44 PM
User is offline View Users Profile Print this message

Author Icon
UcouldBrong
Case Modder

Posts: 811
Joined: 01/05/2013

Things to try:

Study motherboard manual.

Be sure System "High Performance" power settings enabled.

Thermal Gate...opened or closed?  Fan installed?

Run cpu at stock 3.5 and voltage.  Overclocked manually or turbo to what value?  Cpu voltage adjusted?  36C temp is for cpu? When? (idle/heavy gaming)

Run fans in manual at 40-50% in CCC. Gpu temps (idle/gaming)?

Disable onboard graphics.

Dual BIOS switch set to stock on both cards.

Leave gpu memory clock stock.

Disable ULPS.

Disable V Sync.

Run system at 16 Gb RAM, 32; stock timings.  Check memory freq and timings when OC'd.

 



-------------------------

 


 


Non-noob components.



Edited: 02/18/2014 at 04:29 PM by UcouldBrong
 02/18/2014 06:54 PM
User is offline View Users Profile Print this message

Author Icon
TigerOnTheProwl
Peon

Posts: 4
Joined: 02/18/2014

Thanks for the tips.  My thermal gate is open, but my fan is not installed.  I manually OC'd my CPU and have tried it with the stock voltage as well, but to no avail.  36C is the temp of my GPU's while gaming.  Normally they're at around 32.  I've also once had them at close to 40 when I was testing them with the Furmark Benchmark test (which will also crash my computer if Crossfire is enabled).  My CPU has never been higher than 34.  It's usually around 31.  I currently have my GPU fans manually set at 20% but I will try it at some other values.  I never even thought about onboard graphicsl.  I'll disable it.  I believe I have the dual BIOS switch set on both cards but I will double check.  I'll also disable ULPS and V-Sync, and I try changing how much RAM I'm using.  I'll get back to you once I've tried all that.  Thanks for the advice.

 02/18/2014 11:15 PM
User is offline View Users Profile Print this message

Author Icon
TigerOnTheProwl
Peon

Posts: 4
Joined: 02/18/2014

Thank you so much!  One of those appears to have fixed it.  I'm not sure exactly which one since I did all of it at once.  I've had Crysis 3 running for over an hour without any issues, when before, I'd be lucky if it made it to the main menu.  I'm only running with 16 gigs of RAM right now, but I'm going to put that back to 64 and see if the issue comes back.  If it does, at least I'll have narrowed it down.  If you don't hear from me again, it's probably working.  Thanks again.

Statistics
86425 users are registered to the AMD Support and Game forum.
There are currently 6 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.