Topic Title: 8650G+8670M Dual Grphics not Working
Topic Summary: My dual graphics dosen't changes frame-rate with any 13.XX (or 14.1 beta), also no status icon is shown.
Created On: 02/27/2014 03:38 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 02/27/2014 03:38 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 1
Joined: 02/27/2014

I have an HP e001AX Notebook with A10-5750m with 8650G+8670M. The notebook came with single 8GB ram, which I replaced for two 4GB 1600MHz sticks(as I heard dual graphics require dual channel memory). I tried downloading the latest stable drivers from AMD support(tried it with the 14.1 beta also). After insatllation the hardware info now shows linked adapter is 8600M(instead of 8670M). also when using AMD system monitor it only shows that only discrete graphics is processing and the internal is shown idle. Also in the taskbar icon it shows four 8650G(three of which only have options to extend display), and i've checked the option to show the dual graphics icon when applicable but it never does shows up. I've tested it with Crysis 3, Tomb Raider, Assassin Creed 4 and Need For Speed Rivals, but I get no performance change at all with Dual Graphics enabled. Please help!

Edited: 02/27/2014 at 03:46 AM by nightlyspartan
 03/01/2014 05:55 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 1
Joined: 03/01/2014

I would love to see an answer to this as I have a similar issue, which I will describe in detail below.

I purchased an Asus r510dp-fh11 from newegg and it worked great. Updated to 14.1 drivers and using GPU-Z I could tell it was using dual graphics perfectly. Nice heavy and consistent load on both the 8650g and the 8670m. (I ran two instances of GPU-z side by side to monitor both at the same time).

But then I discovered my display had a dead pixel, so I RMA'd it.

Got the replacement machine - identical hardware(AMD a10-5750m + 8670m w/ 2 gigs of vram and 8gb (2x4gb) of 1600 dual channel ram)

I updated all the windows updates, and then to windows 8.1 (as before). Uninstalled old drivers, installed 14.1 beta drivers.

Now my system is as the original poster's. Before, it showed in GPU-z (and the device manager) each separate GPU, i.e. an entry fro 8670m and another for 8650g(while DXdiag showed the display adapter as a Dual graphics configuration). Now the device manager and GPU-z show an entry for 8600m and the second entry shows '8650g + 8600m dual graphics', which is what I want anyway, but then when I run a game (any game) and monitor it via GPU-z, it shows the 8600m at 99% load, which is fine; and the other entry of '8650g + 8600m dual graphics' to show no load at all most of the time, except for random and sporadic spikes anywhere from 3% up to 78% and then back to 0.

I've tried uninstalling these drivers(14.1 beta), and have tried 14.2 beta as well as the automatic driver detection utility from AMD, which put in 13.251 drivers. Variations in driver edition seem to make no difference to this issue.

I wish I could get back to how it was with my other machine (darn that dead pixel!), as it had somehow correctly installed each GPU individually and utilized both for dual graphics, as opposed to now where I see the 8650g is basically remaining idle while I game.

Any insights would be appreciated.

93410 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.