Topic Title: 14.3 Beta drivers cause Crossfire to only display every other frame
Topic Summary:
Created On: 03/18/2014 11:07 AM
Status: Post and Reply
Linear : Threading : Single : Branch
1 2 Next Last unread
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 03/18/2014 11:07 AM
User is offline View Users Profile Print this message

Author Icon
Divvy
Peon

Posts: 18
Joined: 02/18/2014

As per thread title. If I have 60fps in the FPS counter, I'll only actually see 30fps on the screen. If I disable Crossfire, 60fps is properly 60fps again.

 03/18/2014 01:15 PM
User is offline View Users Profile Print this message

Author Icon
UcouldBrong
Overclocker

Posts: 797
Joined: 01/05/2013

So your screen shows "60" fps and "30" fps simultaneously?  How do you know it is 30?

My testing (so far) shows great crossfire scaling in several games as well as Mantle and DX11 in BF4.

*UPDATE*

May be experiencing no Crossfire scaling frame improvement in ARMA III (Developer Version) at this moment...



-------------------------

 


 


Non-noob components.



Edited: 03/18/2014 at 02:08 PM by UcouldBrong
 03/19/2014 10:17 AM
User is offline View Users Profile Print this message

Author Icon
LuckyB
Peon

Posts: 8
Joined: 03/19/2014

Yes, same issue here, you need to enable vsync to see it.

 

The audio glitch is no longer present but the performance is just awful when you enable vsync when crossfire is enabled.



-------------------------

Intel Core i7-4930k
Asus X79-Deluxe
32GB Ballistix Tactical LP 1600MHZ
MSI Gaming R9 290 CrossFireX
Soundblaster ZX
Corsair AX850
Dell UP2414Q
Silverstone FT02

 03/20/2014 07:26 AM
User is offline View Users Profile Print this message

Author Icon
Divvy
Peon

Posts: 18
Joined: 02/18/2014

It's displaying exactly half the refresh rate worth of frames. If you set your display to 120hz, you will see 60fps. If you set 60hz, you will see 30fps. If you set 24hz, you will see 12fps. Disable Crossfire or vsync and it's back to normal again.

 03/20/2014 08:08 AM
User is offline View Users Profile Print this message

Author Icon
Agente Silva
Peon

Posts: 23
Joined: 02/26/2014

So, 14.3 beta are out? Are they any better than 14.2? I tried these with 2*R9 280X (Mantle and DX11) and performance is way worst in BF4...



-------------------------
 03/20/2014 11:23 AM
User is offline View Users Profile Print this message

Author Icon
UcouldBrong
Overclocker

Posts: 797
Joined: 01/05/2013

Please define "way worst".



-------------------------

 


 


Non-noob components.

 03/22/2014 09:07 AM
User is offline View Users Profile Print this message

Author Icon
Divvy
Peon

Posts: 18
Joined: 02/18/2014

Originally posted by: Divvy It's displaying exactly half the refresh rate worth of frames. If you set your display to 120hz, you will see 60fps. If you set 60hz, you will see 30fps. If you set 24hz, you will see 12fps. Disable Crossfire or vsync and it's back to normal again.

 

Still haven't found a solution.

 03/22/2014 11:50 AM
User is offline View Users Profile Print this message

Author Icon
UcouldBrong
Overclocker

Posts: 797
Joined: 01/05/2013

Friend of mine suggests that:  "...you read the manuals."



-------------------------

 


 


Non-noob components.

 03/22/2014 06:41 PM
User is offline View Users Profile Print this message

Author Icon
LuckyB
Peon

Posts: 8
Joined: 03/19/2014

Originally posted by: UcouldBrong Friend of mine suggests that:  "...you read the manuals."

 

 

Real useful comment

Do you have a  crossfire of 290(x).

If so, load up any game with crossfire enabled and vsync enabled, you'll see the problem



-------------------------

Intel Core i7-4930k
Asus X79-Deluxe
32GB Ballistix Tactical LP 1600MHZ
MSI Gaming R9 290 CrossFireX
Soundblaster ZX
Corsair AX850
Dell UP2414Q
Silverstone FT02

 03/23/2014 12:08 AM
User is offline View Users Profile Print this message

Author Icon
UcouldBrong
Overclocker

Posts: 797
Joined: 01/05/2013

Read TFM!



-------------------------

 


 


Non-noob components.

 03/24/2014 07:08 AM
User is offline View Users Profile Print this message

Author Icon
Divvy
Peon

Posts: 18
Joined: 02/18/2014

I noted that Thief 4 doesn't suffer from this problem with Mantle enabled. It does if Mantle is disabled, just like any other DX application.

 03/24/2014 09:31 AM
User is offline View Users Profile Print this message

Author Icon
kevrevrun
Peon

Posts: 3
Joined: 03/24/2014

I am not even getting that far with the 14.2 or 14.3 with dual Saphire 7770 i get driver crash and BSOD in Windows 7 SP1.

 03/24/2014 09:33 AM
User is offline View Users Profile Print this message

Author Icon
kevrevrun
Peon

Posts: 3
Joined: 03/24/2014

It was fine in 14.1 but unfortunately i cant find that file anywhere.

 03/25/2014 08:22 AM
User is offline View Users Profile Print this message

Author Icon
t77chevy
Peon

Posts: 19
Joined: 03/08/2014

I'm running crossfire r9 290x with windows 8.1 and had the same issue in both 4.2 and 4.3 until I remembered that every driver update requires me to manually turn off ulps in registry which solved the problems for me..I'm currently at work so I can't give you set by step but a quick Google search will walk you through it..it's easy to do and not all sites tell you but after changing a pc restart must be done before it takes effect. Hope this helps 

 

73

 03/27/2014 07:24 AM
User is offline View Users Profile Print this message

Author Icon
Agente Silva
Peon

Posts: 23
Joined: 02/26/2014

Originally posted by: UcouldBrong Please define "way worst".

 

Late reply

Way worst: with Mantle FPS drop to 35-50 (where in Cat 13.12 I get 70-120). With DX11 FPS drop to 50-70 (same map, same server)

Running them with Eyefinity (5760*1080)



-------------------------
 03/27/2014 10:57 AM
User is offline View Users Profile Print this message

Author Icon
UcouldBrong
Overclocker

Posts: 797
Joined: 01/05/2013

Solution is obvious...



-------------------------

 


 


Non-noob components.

 03/31/2014 04:14 PM
User is offline View Users Profile Print this message

Author Icon
Elusiveparticle
Peon

Posts: 10
Joined: 03/04/2014

What is the solution if it is obvious? 

I notice a huge performance drop as the OP said in Far Cry 3 when I enable Vsync with crossfire on. I got Windows 8.1 64 bit and 2 r9 290 XFX DDs. The issue goes away when I turn Vsync off. I haven't tried it in other games yet.

 04/01/2014 06:47 AM
User is offline View Users Profile Print this message

Author Icon
Divvy
Peon

Posts: 18
Joined: 02/18/2014

I seem to have found a workaround! By setting the FPS limit to 60 in MSI Afterburner, the FPS halving effect stopped occurring. I'm now getting the full 60fps visually without frame skipping. If I set the FPS limit higher, I get the halving effect again. I think the problem occurs when the CPU is allowed to pre-render frames ahead of the GPU. I believe the FPS limit in Afterburner prevent the CPU from preparing extra frames and the problem is avoided.

 

EDIT: Unfortunately the 60fps limit fixes the halving inconsistently. At one moment it works, the next moment it doesn't work. 59fps limit removes the halving completely but the one skipped frame every second is very noticeable.



Edited: 04/01/2014 at 06:58 AM by Divvy
 04/02/2014 08:40 PM
User is offline View Users Profile Print this message

Author Icon
andrea_gi
Peon

Posts: 7
Joined: 04/02/2014

I see that too with dirt 3, vsynch on render only 30 fps it seems but rivatuner show 60 fps

 04/04/2014 04:00 AM
User is offline View Users Profile Print this message

Author Icon
Divvy
Peon

Posts: 18
Joined: 02/18/2014

Please, andrea_gi and everyone else having this issue, post your complete PC specs. Let's find the common denominator.

Statistics
84289 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.