Topic Title: Dual setup, worse framerate/benchmark?
Topic Summary: Radeon 8670D + 6450
Created On: 04/06/2014 09:13 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 04/06/2014 09:13 PM
User is offline View Users Profile Print this message

Author Icon
Zenoxio
Peon

Posts: 4
Joined: 04/06/2014

I have a Lenovo PC that came with an integrated Radeon 8670D. I also bought a Radeon 6450 card and installed that. Both have up-to-date drivers.

Running the FFXIV:ARR benchmark on medium & fullscreen, I got a benchmark score of 3668. I confirmed in the Catalyst Control Center that the 8670D was the enabled driver.

I then turned on Dual Graphics and confirmed this in dxdiag. I ran the benchmark again, same settings. I then got a lower score of 3594...

What's wrong? How can I fix this?

 04/07/2014 02:44 PM
User is offline View Users Profile Print this message

Author Icon
UcouldBrong
Case Modder

Posts: 811
Joined: 01/05/2013

What results are you getting just using the 6450?

Tests results will frequently change.



-------------------------

 


 


Non-noob components.

 04/07/2014 03:54 PM
User is offline View Users Profile Print this message

Author Icon
Zenoxio
Peon

Posts: 4
Joined: 04/06/2014

The 6450 I couldn't get enabled alone. There were no options in Catalyst Control Center to force it as primary.

Also plugging the monitor directly into the 6450 (instead of onboard 8670D) resulted in a black screen (orange monitor light) on boot, even for the BIOS.

Windows detects the 6450 just fine though.

Any thoughts?

 04/07/2014 08:01 PM
User is offline View Users Profile Print this message

Author Icon
UcouldBrong
Case Modder

Posts: 811
Joined: 01/05/2013

Go into BIOS and configure from there.



-------------------------

 


 


Non-noob components.

 04/07/2014 08:09 PM
User is offline View Users Profile Print this message

Author Icon
Zenoxio
Peon

Posts: 4
Joined: 04/06/2014

Yep tried that already, no luck. This is my only video setting in the BIOS: http://i.imgur.com/8uKQa7H.jpg

I changed it from AUTO to PEG which would make sense, but that did not disable the 8670D at all nor did it change 6450 to primary. Plugging monitor into 6450 after that BIOS change still left my monitor blank.

 04/08/2014 12:42 AM
User is offline View Users Profile Print this message

Author Icon
UcouldBrong
Case Modder

Posts: 811
Joined: 01/05/2013

Too bad.  In the future please post full specs including model number of the PC, motherboard, etc, etc. as it is very difficult to troubleshoot a system with just two pieces of gpu information. 

 

 



-------------------------

 


 


Non-noob components.

 04/09/2014 09:56 PM
User is offline View Users Profile Print this message

Author Icon
Zenoxio
Peon

Posts: 4
Joined: 04/06/2014

Sorry about that. It's a Lenovo H535

CPU: A10-Series APU A10-6700
RAM: 2GB DDR3
OS: Win8 64bit 

 04/11/2014 02:39 AM
User is offline View Users Profile Print this message

Author Icon
UcouldBrong
Case Modder

Posts: 811
Joined: 01/05/2013

2 GB of RAM??



-------------------------

 


 


Non-noob components.

Statistics
86454 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.