Topic Title: R9-290x
Topic Summary: crossfire
Created On: 04/27/2014 07:02 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 04/27/2014 07:02 AM
User is offline View Users Profile Print this message

Author Icon
ilmrebel
Peon

Posts: 14
Joined: 12/05/2007

Short and simple, bought 2 290x, 13.12 works but no crossfire, 14.4 does not complete install without crashing computer, so playing around I downloaded visual studio 2014 from MS, crossfire works like a charm, 14.4 still crashes during install. So some reason the drivers in visual studio helped kick in my crossfire with 13.12, had these cards 2 months without crossfire and tried several amd drivers, so if anyone has this problem try the visual studio dl, its free and might help amd drivers kick in.

 04/27/2014 12:10 PM
User is offline View Users Profile Print this message

Author Icon
Tam3n
Peon

Posts: 4
Joined: 04/27/2014

I have 2x R9 290, I'm using the 13.11 Beta9, these are not perfect but the 14.4 gives me BSODs with flash videos and other versions have various problems too... If I remember corretly the 13.12 has crossfire stuttering & sound issues... But good if it works for you.

 04/27/2014 04:20 PM
User is offline View Users Profile Print this message

Author Icon
ilmrebel
Peon

Posts: 14
Joined: 12/05/2007

Heres the actual softie table i am using now stable.

Driver Packaging Version    13.35.1005-140312a-169198E
Catalyst Version    14.3
Provider    Advanced Micro Devices, Inc.
2D Driver Version    8.01.01.1390
2D Driver File Path    /REGISTRY/MACHINE/SYSTEM/ControlSet001/Control/Class/{4d36e968-e325-11ce-bfc1-08002be10318}/0007
Direct3D Version    9.14.10.01029
OpenGL Version    6.14.10.12874
AMD Catalyst Control Center Version    2014.0312.1131.18796

 05/03/2014 12:47 AM
User is offline View Users Profile Print this message

Author Icon
John77
Peon

Posts: 4
Joined: 05/03/2014

I just added a second 290X for crossfire but when I run crossfire I get sound issues and stuttering...I have tried all the AMD drivers etc. to try and get it to work but nothing seems to help.  When I turn off crossfire and just run one card I have NO issues at all with games...just lost of FPS.

If anyone had any info or help I would love it...sucks going crossfire just to not have it work.

Statistics
84980 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.