Topic Title: R9 290X Crossfire - Performance worse than single GPU
Topic Summary: Crossfire performance worse than single GPU
Created On: 05/04/2014 12:20 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 05/04/2014 12:20 PM
User is offline View Users Profile Print this message

Author Icon
stuste
Peon

Posts: 1
Joined: 05/04/2014

Hi guys,

What started as a problem with Skyrim, turned out to be a bigger problem with my system. Basically for some reason I am getting lower performance and stuttering with Crossfire on. 

At first I thought it had something to do with Skyrim, however after checking I can say that I am getting lower performance with Crossfire in all games, together with some horrible stuttering.

I copied the following from a post I have on overclock.net so you can check it if you need some extra information regarding my system. Since I cannot post links, I'll copy everything here.

Here are my Unigine Heaven Benchmark test results.

Unigine Heaven Benchmark 4.0

FPS:
26.6
Score:
671
Min FPS:
7.1
Max FPS:
53.1
System

CPU model:
Intel(R) Core(TM) i7-3770K CPU @ 3.50GHz (3499MHz) x4 <-- This has been OCed to 4.5GHz
GPU model:
AMD Radeon R9 200 Series 14.100.0.0 (4095MB) x2
Settings

Render:
Direct3D11
Mode:
2560x1440 8xAA fullscreen
Preset
Custom <-- This is everything maxed out.
Quality
Ultra
Tessellation:
Extreme

So this is happening in every game. I am getting lower performance with Crossfire on, than with Crossfire off. I just did a clean format, swapped the position of the cards (I put the top one on the bottom and vice versa). turned on the Uber bios mode, and it's still the same.
According to GPU-Z my cards are running on PCI-E 3.0 x 16 @ x8 3.0 interfaces (which is due to my Asus P8Z77 Deluxe which can use only one card at x16, but if used in SLI/Crossfire, the two ports go to x8), however I do not believe this is the problem.

Not only am I experiencing lower performance and stuttering in all games that I've checked with Crossfire enabled, I am experiencing the graphic bugs with the ENBs in Skyrim - stuttering and white/extremely bright sky. I have tried turning Frame Pacing on or off without any effect.

The only thing different in GPU-Z is that one card has GDDR5 Elpida Memory Type, while the other one has Hynix, but if I understand correctly this shouldn't have this effect?

What other troubleshooting can I do? So far I've checked that the CPU temp is stable at 55-60 at max usage, my HDDs are fine, 1000W CoolerMaster CPU is more than enough, and I am out of ideas. If one of the cards was defective I should have gotten worse performance in single GPU mode after swapping them, however the same thing happens - single GPU performance > Crossfire. I am clearly out of ideas, except for maybe some problem with the motherboard, however it was bought about a year ago, and I didn't have a problem 1 month ago when I had 2xGTX 680s in the same slots as the R9 290Xs now.

CPU
Intel Core i7 3770k OCed to 4.4GHz Liquid Cooled(S1366, 2.80GHz)

Motherboard
Asus P8Z77-Deluxe

Graphics
2 x AMD R9 290X (PCI-Express 3.0, GDDR5, 4096 MB)

RAM
Corsair Vengeance 16GB DDR3-1600 Ram (PC3 12800, 8-8-8-24

Hard Drive
2 x Samsung 840 RAID0 SSD

OS
Windows 8.1 64 bit

Monitor
Samsung Series 9 27" 1440p LS27B970DS

PSU
CoolerMaster Silent Pro M1000 1000W

Case
CM Storm Trooper

Audio
Asus Xonar DX + ATH-M50


Thanks,

 05/05/2014 01:02 AM
User is offline View Users Profile Print this message

Author Icon
John77
Peon

Posts: 4
Joined: 05/03/2014

Well I wish I could help you..but I am in the same boat as you.  I am running a solo R 290X until they fix crossfire or until I can find a fix myself.  Good luck.

 

 05/05/2014 01:21 PM
User is offline View Users Profile Print this message

Author Icon
UcouldBrong
Case Modder

Posts: 801
Joined: 01/05/2013

Most Crossfire users have found that some games realize no benefit from multi gpus.   Doesn't take much to run a DX9 game.



-------------------------

 


 


Non-noob components.

 05/12/2014 02:44 PM
User is offline View Users Profile Print this message

Author Icon
thomasbo
Peon

Posts: 2
Joined: 05/12/2014

HI,

 

Have same problem.

 

2 x 290x with MANTLE give me 50% the fps as in DirectX in BF4. GPU load goes between 100% and 3% on both cards.. one up.. the other down.. and next second the other way around.. never two cards at 100% load.

Statistics
85483 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.