Topic Title: R9 295x2 no Crossfire Option in Catalyst Control Center
Topic Summary:
Created On: 06/26/2014 08:33 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 06/26/2014 08:33 AM
User is offline View Users Profile Print this message

Author Icon
Cheph
Peon

Posts: 5
Joined: 06/26/2014

Hi!

 

I am new to Radeon-AMD Drivers, and Catalyst Center is also new for me.

is there no Option in Catalyst Control Center to enable a Checkbox for Crossfire?

using the new Beta Driver

 

 06/26/2014 09:36 AM
User is offline View Users Profile Print this message

Author Icon
HoneyBadger84
Button Masher

Posts: 205
Joined: 06/10/2014

As far as I know Crossfire is automatically enabled once drivers are installed and you reboot on a r9 295x2, check with GPUz to ensure its enabled. There should be an option under  Peformance & gaming both in CCC:

 



-------------------------

CPU: i7 3930k @ 4.6GHz 1.29V (Corsair H110-cooled) ~ Motherboard: Asus RoG Rampage IV Extreme 
RAM: G.Skill Sniper Gaming Series (4x4GB 2133MHz, CL9) ~ PSU: Corsair AX 1200W ~ Case: Enermax Fulmo GT
GPUs: 3x HIS R9 290X Reference (Core) Editions in TriFire, Max Load Temps: 71C/70C/71C during OC testing :-P

 06/26/2014 09:42 AM
User is offline View Users Profile Print this message

Author Icon
Cheph
Peon

Posts: 5
Joined: 06/26/2014

GPUZ shows that the Card is Running Crossfire, but i have no Option in Gaming or Performance Tabs.

 

maybe there is no Option for R9 295x2 Cards in CCC?



Edited: 06/26/2014 at 09:49 AM by Cheph
 06/26/2014 10:28 AM
User is offline View Users Profile Print this message

Author Icon
backFireX64
Ubergeek

Posts: 1860
Joined: 11/14/2010

Originally posted by: Cheph GPUZ shows that the Card is Running Crossfire, but i have no Option in Gaming or Performance Tabs.

 

 

 

maybe there is no Option for R9 295x2 Cards in CCC?

 

 

No, i don't think there is for dual-gpu cards on ccc. Only an option to enable crossfirex in games that do not have a crossfire profile.

 

Make sure you check the "information" tab --> "hardware" tab.

Does ccc report both adapters enabled, and with what maximum bus setting (for example: x16) ?



-------------------------

gigabyte X58A-UD3R rev.2, core i7 975 3.9ghz (stock voltage), windows 8.1 64-bit, corsair 12gb DDR3 1600mhz 7-7-7-20 RAM, xfx HD 5970 + gigabyte HD 5970 (950mhz/ 1100mhz), coolermaster ultimate 900w PSU.
amd catalyst 14.12 Omega Driver

 06/26/2014 10:30 AM
User is offline View Users Profile Print this message

Author Icon
Cheph
Peon

Posts: 5
Joined: 06/26/2014

I will check this later, when i am at Home.

 

Thank You !

 06/26/2014 10:35 AM
User is offline View Users Profile Print this message

Author Icon
backFireX64
Ubergeek

Posts: 1860
Joined: 11/14/2010

You are welcome.



-------------------------

gigabyte X58A-UD3R rev.2, core i7 975 3.9ghz (stock voltage), windows 8.1 64-bit, corsair 12gb DDR3 1600mhz 7-7-7-20 RAM, xfx HD 5970 + gigabyte HD 5970 (950mhz/ 1100mhz), coolermaster ultimate 900w PSU.
amd catalyst 14.12 Omega Driver

 06/27/2014 06:04 AM
User is offline View Users Profile Print this message

Author Icon
HoneyBadger84
Button Masher

Posts: 205
Joined: 06/10/2014

That is very odd.  Every dual GPU card I've ever had has had the option to disable the connection, I've run 9800GX2s (old card but still the point) and HD 6990s, they both had options to run single GPU mode in NVCP/CCC. I'll check in to if this is not available for the r9 295x2.



-------------------------

CPU: i7 3930k @ 4.6GHz 1.29V (Corsair H110-cooled) ~ Motherboard: Asus RoG Rampage IV Extreme 
RAM: G.Skill Sniper Gaming Series (4x4GB 2133MHz, CL9) ~ PSU: Corsair AX 1200W ~ Case: Enermax Fulmo GT
GPUs: 3x HIS R9 290X Reference (Core) Editions in TriFire, Max Load Temps: 71C/70C/71C during OC testing :-P

 06/27/2014 10:21 AM
User is offline View Users Profile Print this message

Author Icon
backFireX64
Ubergeek

Posts: 1860
Joined: 11/14/2010

Yea, i believe either ati/ amd dropped this feature in later ccc installments (don't quite remember), or it only applies if you crossfire a dual-gpu card with another dual-gpu card (quadfire).



-------------------------

gigabyte X58A-UD3R rev.2, core i7 975 3.9ghz (stock voltage), windows 8.1 64-bit, corsair 12gb DDR3 1600mhz 7-7-7-20 RAM, xfx HD 5970 + gigabyte HD 5970 (950mhz/ 1100mhz), coolermaster ultimate 900w PSU.
amd catalyst 14.12 Omega Driver

 06/28/2014 08:00 AM
User is offline View Users Profile Print this message

Author Icon
HoneyBadger84
Button Masher

Posts: 205
Joined: 06/10/2014

After some research it seems that currently there is no disable crossfire option at all for the r9 295x2 to allow you to run in single gpu mode. Maybe it'll be enabled in coming drivers. It is sited on a few buyer/owner reviews as one of the only downsides. 



-------------------------

CPU: i7 3930k @ 4.6GHz 1.29V (Corsair H110-cooled) ~ Motherboard: Asus RoG Rampage IV Extreme 
RAM: G.Skill Sniper Gaming Series (4x4GB 2133MHz, CL9) ~ PSU: Corsair AX 1200W ~ Case: Enermax Fulmo GT
GPUs: 3x HIS R9 290X Reference (Core) Editions in TriFire, Max Load Temps: 71C/70C/71C during OC testing :-P

 06/28/2014 08:10 AM
User is offline View Users Profile Print this message

Author Icon
backFireX64
Ubergeek

Posts: 1860
Joined: 11/14/2010

Originally posted by: HoneyBadger84 After some research it seems that currently there is no disable crossfire option at all for the r9 295x2 to allow you to run in single gpu mode. Maybe it'll be enabled in coming drivers. It is sited on a few buyer/owner reviews as one of the only downsides. 

 

 

And that is exactly the reason why my next crossfirex build won't include any dual-gpu cards whatsoever.



-------------------------

gigabyte X58A-UD3R rev.2, core i7 975 3.9ghz (stock voltage), windows 8.1 64-bit, corsair 12gb DDR3 1600mhz 7-7-7-20 RAM, xfx HD 5970 + gigabyte HD 5970 (950mhz/ 1100mhz), coolermaster ultimate 900w PSU.
amd catalyst 14.12 Omega Driver

 06/28/2014 08:17 AM
User is offline View Users Profile Print this message

Author Icon
HoneyBadger84
Button Masher

Posts: 205
Joined: 06/10/2014

Originally posted by: backFireX64
Originally posted by: HoneyBadger84 After some research it seems that currently there is no disable crossfire option at all for the r9 295x2 to allow you to run in single gpu mode. Maybe it'll be enabled in coming drivers. It is sited on a few buyer/owner reviews as one of the only downsides. 

 

 

 

 

 

 

And that is exactly the reason why my next crossfirex build won't include any dual-gpu cards whatsoever.

 

That's been the crux of dual-gpu-card based quadfire for a while, no way to select between 1-2-3-4 gpus, even with 6990s it was 1, 2 or 4. Whereas with 4 actual cards that are separate you can choose single, dual, tri or quadfire, and you can even specify which cards you want to use in a 2/3 card configuration. 



-------------------------

CPU: i7 3930k @ 4.6GHz 1.29V (Corsair H110-cooled) ~ Motherboard: Asus RoG Rampage IV Extreme 
RAM: G.Skill Sniper Gaming Series (4x4GB 2133MHz, CL9) ~ PSU: Corsair AX 1200W ~ Case: Enermax Fulmo GT
GPUs: 3x HIS R9 290X Reference (Core) Editions in TriFire, Max Load Temps: 71C/70C/71C during OC testing :-P

 06/28/2014 10:21 AM
User is offline View Users Profile Print this message

Author Icon
backFireX64
Ubergeek

Posts: 1860
Joined: 11/14/2010

Exactly.

 

Though, you do have to bring a high class motherboard equipped with some good speed/ link width lane pcie slots now, don't you ?

 

And that can hurt a lot of people's pc building budget.

 

Oh...... the lucky few.....



-------------------------

gigabyte X58A-UD3R rev.2, core i7 975 3.9ghz (stock voltage), windows 8.1 64-bit, corsair 12gb DDR3 1600mhz 7-7-7-20 RAM, xfx HD 5970 + gigabyte HD 5970 (950mhz/ 1100mhz), coolermaster ultimate 900w PSU.
amd catalyst 14.12 Omega Driver

 06/30/2014 08:38 PM
User is offline View Users Profile Print this message

Author Icon
deadbc77
Peon

Posts: 7
Joined: 06/11/2014

Crossfire is automatic for my R9 295X2,but when i add a third card then the Crossfire option shows up in CCC.

 07/01/2014 05:54 AM
User is offline View Users Profile Print this message

Author Icon
backFireX64
Ubergeek

Posts: 1860
Joined: 11/14/2010

Originally posted by: deadbc77 Crossfire is automatic for my R9 295X2,but when i add a third card then the Crossfire option shows up in CCC.

 

 

Yes, that is normal.

 

Internal crossfirex in a dual-gpu does not have currently an option to toggle in CCC. You can only add a custom profile of a specific game and disable or enable crossfirex there, for that game, not globally.

Now, two or three physical display cards, with a maximum combination of 4 GPU's (quadfire) will show an extra option for crossfirex in CCC.

 

Thanks for the feedback deadbc77.



-------------------------

gigabyte X58A-UD3R rev.2, core i7 975 3.9ghz (stock voltage), windows 8.1 64-bit, corsair 12gb DDR3 1600mhz 7-7-7-20 RAM, xfx HD 5970 + gigabyte HD 5970 (950mhz/ 1100mhz), coolermaster ultimate 900w PSU.
amd catalyst 14.12 Omega Driver

 11/03/2014 11:17 AM
User is offline View Users Profile Print this message

Author Icon
ever1ast
Peon

Posts: 19
Joined: 11/01/2014

I have a thread open in the Drivers section, XFX support, and Sapphire support at the moment regarding r9 295x2s as well. (here)

Internal crossfirex in a dual-gpu does not have currently an option to toggle in CCC. You can only add a custom profile of a specific game and disable or enable crossfirex there, for that game, not globally.

 

Now, two or three physical display cards, with a maximum combination of 4 GPU's (quadfire) will show an extra option for crossfirex in CCC.

I currently have 2 of them (4 GPUS) and this isn't the case.  I can't get catalyst control to display the crossfire option either -- with 1 card installed or 2 it makes no difference.  Even stranger yet... under the 3D application settings it cleary shows CrossfireX Frame pacing options.

 

To make matters worse, each card shows crossfire is enabled between the two onboard GPUs, but quad crossfire won't work.  I'm seeing 2 seperate 2-card configurations, which means one of my $1000 cards is essentially useless for gaming at the moment.

 

I've been through every forum with info on the 295x2s and tried every solution I've come across (see my thread if you're curious), but nothing seems to do the trick.  I know it's a driver issue, but with no ETA or even official response from AMD or the subvendors it's making me rethink my card choices right now.  Never had these problems when I built personal or client 4-way SLI configurations with NVIDIA.



Edited: 11/03/2014 at 11:25 AM by ever1ast
 11/03/2014 06:28 PM
User is offline View Users Profile Print this message

Author Icon
Vegan
Alpha Geek

Posts: 1438
Joined: 01/31/2010

Originally posted by: Cheph Hi!

 

 

 

I am new to Radeon-AMD Drivers, and Catalyst Center is also new for me.

 

is there no Option in Catalyst Control Center to enable a Checkbox for Crossfire?

 

using the new Beta Driver

 

 

 

I have both AMD and NVIDIA gaming cards and AMD is automatic while NVIDIA requires some intervention

Right now I have one HD 6970 but there are lots more where that came from.

 



-------------------------

 11/12/2014 11:28 AM
User is offline View Users Profile Print this message

Author Icon
leo8815
Peon

Posts: 3
Joined: 11/11/2014

HoneyBadger84 have you tried using Display Driver Uninstaller? I would recommend running that program in safe mode. It will make sure the amd Catalyst drivers are completely removed even the registry keys in Windows.

Once that's done install catalyst beta drivers 14.11.1 should have your crossfire options restored. I am currently using catalyst beta drivers 14.11.1  for my pair of 295x2's my cards are working great!

 



-------------------------

@

 11/14/2014 11:54 AM
User is offline View Users Profile Print this message

Author Icon
alexliangzhiwei
Peon

Posts: 2
Joined: 11/14/2014

Hi, it seems like I ve encounter the same problem, however, even GPU-z shows disabled in the crossfire section.

 

I ve tried display driver uninstaller, no luck, any suggesttion?

 11/16/2014 11:43 PM
User is offline View Users Profile Print this message

Author Icon
ever1ast
Peon

Posts: 19
Joined: 11/01/2014

Originally posted by: alexliangzhiwei Hi, it seems like I ve encounter the same problem, however, even GPU-z shows disabled in the crossfire section.

 

I ve tried display driver uninstaller, no luck, any suggesttion?

 

Alex, 

I too have been experienceing crossfire issues with these cards.  Here's a full list of what I've tried so far.  Hopefully something helps you.

 

My MB manufacturer has told me twice now that this could be a R9 295x2 VBIOS compatability issue with the chipset I'm using (x99). All the evidence I've gathered points to either that or an AMD driver issue.  

In the interest of narrowing down the possibilities, what platform are you on / what are your system specs?



Edited: 11/16/2014 at 11:50 PM by ever1ast
Statistics
88750 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.