Topic Title: R9 270X X2 Crossfire Help
Topic Summary:
Created On: 07/13/2014 11:34 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 07/13/2014 11:34 PM
User is offline View Users Profile Print this message

Author Icon
Scruffi
Peon

Posts: 2
Joined: 07/13/2014

Hi all,

Some help would be greatly appreciated

My specs:

i5 4690k @ 3.4ghz

16gb DDR3 Ram

RM750 PSU

ASRock H97 Fatal1ty Mobo

And 2 New Sapphire R9 270x OC editions

I have a clean install of windows 8.1, up to date CCC and a crossfire bridge installed yet i get no option to turn on Crossfire when I tested each card independently they worked fine. When both of them are installed they work fine but i have no option to turn on Crossfire. The second one shows as linked (see here: http://puu.sh/aaoex/defc1c9ccb.png) and i get about a 12 fps gain by having a second card (from furmark 720p Burn in test) Not sure if this is the full potential or if they arent right.

 

Thanks in advance,

Scruffi

 07/14/2014 12:37 AM
User is offline View Users Profile Print this message

Author Icon
Earnhardt
Case Modder

Posts: 895
Joined: 09/11/2008

Originally posted by: Scruffi Hi all,

 

Some help would be greatly appreciated

 

My specs:

 

i5 4690k @ 3.4ghz

 

16gb DDR3 Ram

 

RM750 PSU

 

ASRock H97 Fatal1ty Mobo

 

And 2 New Sapphire R9 270x OC editions

 

I have a clean install of windows 8.1, up to date CCC and a crossfire bridge installed yet i get no option to turn on Crossfire when I tested each card independently they worked fine. When both of them are installed they work fine but i have no option to turn on Crossfire. The second one shows as linked (see here: http://puu.sh/aaoex/defc1c9ccb.png) and i get about a 12 fps gain by having a second card (from furmark 720p Burn in test) Not sure if this is the full potential or if they arent right.

 

 

 

Thanks in advance,

 

Scruffi

 

 

Try a different benchmark,like Unigine heaven,valley maybe even 3Dmark..Do it with crossfire disabled and enabled.

these are what mine are with the specs below:



-------------------------

AMD Phenom II 1100t @4.0Ghz /Asus sabertooth 990fx/2x Gigabyte 3G 7950's in crossfire/500G samsung 840 ssd/16G G-Skill Ripjaw 1600/2-samsung 24" monitors 1920X1200/Corsair AX1200W psu/W7 pro 64,G19 keyboard,Roccat kone pure mouse,Cooler master HAF932,Corsair H100i water cooler,Zalman ram cooler.Sound Blaster X-Fi Titanium Fatal1ty Champion Series,Logitech Z5500 speakers,Roccat Kave 5.1 headset.

 07/14/2014 05:10 AM
User is offline View Users Profile Print this message

Author Icon
Scruffi
Peon

Posts: 2
Joined: 07/13/2014

Thank you for the reply it turns out after about 2 months of farting around it just needed a few more restarts.

Statistics
86438 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.